summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README.source18
-rw-r--r--debian/changelog15
-rw-r--r--debian/control19
-rw-r--r--debian/patches/0100-source_typos.patch2
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules3
6 files changed, 32 insertions, 27 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..e4f2b3d
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,18 @@
+Hello,
+
+now I use the branching model from Vincent Driessen[1].
+
+I use the gitflow-avh[2]. with the Documentation[3].
+The Debian package can be found here[4].
+
+Please upload unattended uploads use a branch feature/<your title>.
+
+
+Many thanks.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Fri, 02 Jun 2017 19:00:40 +0200
+
+[1] http://nvie.com/posts/a-successful-git-branching-model/
+[2] https://github.com/petervanderdoes/gitflow-avh
+[3] https://github.com/petervanderdoes/gitflow-avh/wiki
+[4] https://tracker.debian.org/pkg/git-flow
diff --git a/debian/changelog b/debian/changelog
index 7a8155d..b7b74ad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,19 @@
-libonig (6.2.0-1) unstable; urgency=medium
+libonig (6.3.0-1) unstable; urgency=medium
* New upstream release.
- Update symbols file.
- * Drop dh-autoreconf from both build-depends and dh --with arguments
+ - Refresh patches.
+ * Drop dh-autoreconf from both build-depends and dh --with arguments.
because this is all defaults when using dh compat 10.
* debian/copyright: Add year 2017.
-
- -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 09 Apr 2017 20:00:40 +0200
+ * Remove upstream applied debian/patches/0500-CVE-2017-922[4-9].patch.
+ * Use the automatic debug symbol packages:
+ - Remove libonig4-dbg section from debian/control.
+ - Remove override_dh_strip from debian/rules.
+ * New README.source to explain the branching model used.
+ * Declare compliance with Debian Policy 4.0.0. (No changes needed).
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 25 Jun 2017 09:55:31 +0200
libonig (6.1.3-2) unstable; urgency=high
diff --git a/debian/control b/debian/control
index c5fbb3d..6b25f28 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: extra
Maintainer: Jörg Frings-Fürst <debian@jff-webhosting.net>
Build-Depends:
debhelper (>= 10)
-Standards-Version: 3.9.8
+Standards-Version: 4.0.0
Homepage: https://github.com/kkos/oniguruma
Vcs-Git: https://anonscm.debian.org/cgit/collab-maint/libonig.git
Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/libonig.git
@@ -24,23 +24,6 @@ Description: regular expressions library
Different character encoding for every regular expression object can
be specified.
-Package: libonig4-dbg
-Section: debug
-Architecture: any
-Multi-Arch: same
-Depends:
- ${misc:Depends},
- libonig4 (= ${binary:Version})
-Pre-Depends:
- ${misc:Pre-Depends}
-Description: regular expressions library — debugging symbols
- Oniguruma is a library for working with regular expressions.
- .
- Different character encoding for every regular expression object can
- be specified.
- .
- This package provides the debugging symbols.
-
Package: libonig-dev
Section: libdevel
Priority: optional
diff --git a/debian/patches/0100-source_typos.patch b/debian/patches/0100-source_typos.patch
index fe1bca0..ec96ad2 100644
--- a/debian/patches/0100-source_typos.patch
+++ b/debian/patches/0100-source_typos.patch
@@ -7,7 +7,7 @@ Index: trunk/src/regerror.c
===================================================================
--- trunk.orig/src/regerror.c
+++ trunk/src/regerror.c
-@@ -65,7 +65,7 @@ onig_error_code_to_format(int code)
+@@ -67,7 +67,7 @@ onig_error_code_to_format(int code)
case ONIGERR_UNEXPECTED_BYTECODE:
p = "unexpected bytecode (bug)"; break;
case ONIGERR_DEFAULT_ENCODING_IS_NOT_SETTED:
diff --git a/debian/patches/series b/debian/patches/series
index 06ee93d..2f55f57 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,3 @@
#001-changes_build_sys.diff
0100-source_typos.patch
-0500-CVE-2017-922[4-9].patch
+#0500-CVE-2017-922[4-9].patch
diff --git a/debian/rules b/debian/rules
index 69ed6ac..32be672 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,9 +22,6 @@ VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-
%:
dh $@
-override_dh_strip:
- dh_strip --dbg-package=libonig4-dbg
-
override_dh_install:
$(RM) debian/tmp/usr/bin/onig-config
dh_install --fail-missing -X.la -X.a