summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-03-31 09:27:41 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-03-31 09:27:41 +0200
commitd4ad46303a0fc4b9676add15b5b36c600ac44702 (patch)
tree47241d515e1f75a0fa3fbf4a8149ef12832d9296
parentebe976d011540d05ef335690097d0358f09d628b (diff)
New multiarch-libc.patch
-rw-r--r--debian/changelog4
-rw-r--r--debian/debian/patches/multiarch-libc.patch52
-rw-r--r--debian/patches/0100-float-endian-detection.patch (renamed from debian/patches/float-endian-detection.patch)0
-rw-r--r--debian/patches/0700-multiarch-libc.patch52
-rw-r--r--debian/patches/series3
5 files changed, 110 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d7781e..0be788a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,10 @@ libunistring (0.9.7-1) UNRELEASED; urgency=medium
* debian/copyright:
- Add myself to debian/*.
- Renew licenses and dates.
+ * New debian/patches/0700-multiarch-libc.patch (Closes: #857708).
+ - Use multiarched libc-dev header.
+ Thanks to Helmut Grohne <helmut@subdivi.de>.
+ * Refresh and renumber the patch float-endian-detection.patch.
-- Jörg Frings-Fürst <debian@jff-webhosting.net> Mon, 27 Mar 2017 21:42:44 +0200
diff --git a/debian/debian/patches/multiarch-libc.patch b/debian/debian/patches/multiarch-libc.patch
new file mode 100644
index 0000000..055d57c
--- /dev/null
+++ b/debian/debian/patches/multiarch-libc.patch
@@ -0,0 +1,52 @@
+From: Helmut Grohne <helmut@subdivi.de>
+Subject: fix @HAVE_STDINT_H@ once stdint.h moves to /usr/include/<triplet>
+
+Index: libunistring-0.9.6+really0.9.3/lib/Makefile.am
+===================================================================
+--- libunistring-0.9.6+really0.9.3.orig/lib/Makefile.am
++++ libunistring-0.9.6+really0.9.3/lib/Makefile.am
+@@ -98,28 +98,13 @@
+ echo '#if __GLIBC__ >= 2'; \
+ echo '#include <stdint.h>'; \
+ echo '#else'; \
+- if test -f /usr/include/stdint.h; then \
+- HAVE_STDINT_H='1'; \
+- else \
+- HAVE_STDINT_H='defined __MINGW32__ || defined __HAIKU__'; \
+- fi; \
+- if test -f /usr/include/inttypes.h; then \
+- HAVE_INTTYPES_H='1'; \
+- else \
+- HAVE_INTTYPES_H='defined __MINGW32__ || defined __HAIKU__'; \
+- fi; \
+- if test -f /usr/include/sys/inttypes.h; then \
+- HAVE_SYS_INTTYPES_H='1'; \
+- else \
+- HAVE_SYS_INTTYPES_H='0'; \
+- fi; \
+- sed -e 's/@''HAVE_STDINT_H''@/'"$$HAVE_STDINT_H"'/g' \
++ sed -e 's/@''HAVE_STDINT_H''@/$(or @HAVE_STDINT_H@,0)/g' \
+ -e 's|@''INCLUDE_NEXT''@|include|g' \
+ -e 's|@''PRAGMA_SYSTEM_HEADER''@||g' \
+ -e 's|@''NEXT_STDINT_H''@|<stdint.h>|g' \
+ -e 's/@''HAVE_SYS_TYPES_H''@/1/g' \
+- -e 's/@''HAVE_INTTYPES_H''@/'"$$HAVE_INTTYPES_H"'/g' \
+- -e 's/@''HAVE_SYS_INTTYPES_H''@/'"$$HAVE_SYS_INTTYPES_H"'/g' \
++ -e 's/@''HAVE_INTTYPES_H''@/$(or @HAVE_INTTYPES_H@,0)/g' \
++ -e 's/@''HAVE_SYS_INTTYPES_H''@/$(or @HAVE_SYS_INTTYPES_H@,0)/g' \
+ -e 's/@''HAVE_SYS_BITYPES_H''@/0/g' \
+ < $(srcdir)/stdint.mini.h; \
+ echo '#endif'; \
+Index: libunistring-0.9.6+really0.9.3/configure.ac
+===================================================================
+--- libunistring-0.9.6+really0.9.3.orig/configure.ac
++++ libunistring-0.9.6+really0.9.3/configure.ac
+@@ -136,6 +136,8 @@
+ HEXVERSION=0x`$AWK 'BEGIN { printf("%02d%02d"',"$version_major","$version_minor"') }'`
+ AC_SUBST([HEXVERSION])
+
++AC_CHECK_HEADERS_ONCE(stdint.h inttypes.h sys/inttypes.h)
++
+ dnl Check for tools needed for formatting the documentation.
+ ac_aux_dir_abs=`cd $ac_aux_dir && pwd`
+ AC_PATH_PROG([TEXI2DVI], [texi2dvi], [$ac_aux_dir_abs/missing texi2dvi])
diff --git a/debian/patches/float-endian-detection.patch b/debian/patches/0100-float-endian-detection.patch
index d094516..d094516 100644
--- a/debian/patches/float-endian-detection.patch
+++ b/debian/patches/0100-float-endian-detection.patch
diff --git a/debian/patches/0700-multiarch-libc.patch b/debian/patches/0700-multiarch-libc.patch
new file mode 100644
index 0000000..a732d42
--- /dev/null
+++ b/debian/patches/0700-multiarch-libc.patch
@@ -0,0 +1,52 @@
+From: Helmut Grohne <helmut@subdivi.de>
+Subject: fix @HAVE_STDINT_H@ once stdint.h moves to /usr/include/<triplet>
+
+Index: trunk/lib/Makefile.am
+===================================================================
+--- trunk.orig/lib/Makefile.am
++++ trunk/lib/Makefile.am
+@@ -100,28 +100,13 @@ unistring/stdint.h : $(STDINT_H) stdint.
+ echo '#if __GLIBC__ >= 2'; \
+ echo '#include <stdint.h>'; \
+ echo '#else'; \
+- if test -f /usr/include/stdint.h; then \
+- HAVE_STDINT_H='1'; \
+- else \
+- HAVE_STDINT_H='defined __MINGW32__ || defined __HAIKU__'; \
+- fi; \
+- if test -f /usr/include/inttypes.h; then \
+- HAVE_INTTYPES_H='1'; \
+- else \
+- HAVE_INTTYPES_H='defined __MINGW32__ || defined __HAIKU__'; \
+- fi; \
+- if test -f /usr/include/sys/inttypes.h; then \
+- HAVE_SYS_INTTYPES_H='1'; \
+- else \
+- HAVE_SYS_INTTYPES_H='0'; \
+- fi; \
+- sed -e 's/@''HAVE_STDINT_H''@/'"$$HAVE_STDINT_H"'/g' \
++ sed -e 's/@''HAVE_STDINT_H''@/$(or @HAVE_STDINT_H@,0)/g' \
+ -e 's|@''INCLUDE_NEXT''@|include|g' \
+ -e 's|@''PRAGMA_SYSTEM_HEADER''@||g' \
+ -e 's|@''NEXT_STDINT_H''@|<stdint.h>|g' \
+ -e 's/@''HAVE_SYS_TYPES_H''@/1/g' \
+- -e 's/@''HAVE_INTTYPES_H''@/'"$$HAVE_INTTYPES_H"'/g' \
+- -e 's/@''HAVE_SYS_INTTYPES_H''@/'"$$HAVE_SYS_INTTYPES_H"'/g' \
++ -e 's/@''HAVE_INTTYPES_H''@/$(or @HAVE_INTTYPES_H@,0)/g' \
++ -e 's/@''HAVE_SYS_INTTYPES_H''@/$(or @HAVE_SYS_INTTYPES_H@,0)/g' \
+ -e 's/@''HAVE_SYS_BITYPES_H''@/0/g' \
+ < $(srcdir)/stdint.mini.h; \
+ echo '#endif'; \
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac
++++ trunk/configure.ac
+@@ -142,6 +142,8 @@ version_subminor=`echo "${VERSION}" | se
+ HEXVERSION=0x`$AWK 'BEGIN { printf("%02X%02X%02X"',"$version_major","$version_minor","$version_subminor"') }'`
+ AC_SUBST([HEXVERSION])
+
++AC_CHECK_HEADERS_ONCE(stdint.h inttypes.h sys/inttypes.h)
++
+ dnl Check for tools needed for formatting the documentation.
+ ac_aux_dir_abs=`cd $ac_aux_dir && pwd`
+ AC_PATH_PROG([TEXI2DVI], [texi2dvi], [$ac_aux_dir_abs/missing texi2dvi])
diff --git a/debian/patches/series b/debian/patches/series
index c1d7c66..f107ca4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
-float-endian-detection.patch
+0100-float-endian-detection.patch
+0700-multiarch-libc.patch