summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>2016-05-27 14:35:40 +0100
committerManuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>2016-05-27 14:35:40 +0100
commitb1de003dac299705a7f01c997d2b866bafe39926 (patch)
tree1cc16a3877e945116387a380f7f3023f81fa36e4 /configure.ac
parent752fd7247bc223bcea35bd89cf56d1c08ead9ba6 (diff)
parent3590c846d4c2febbc05b4ad6b14a06edc549e453 (diff)
Merge tag 'upstream/0.9.6+really0.9.6'
Upstream version 0.9.6+really0.9.6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 460244f..38fe5dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ AC_CONFIG_SRCDIR([lib/unistring/version.in.h])
AC_CONFIG_AUX_DIR([build-aux])
. $srcdir/version.sh
gl_INIT_PACKAGE([libunistring], [$VERSION_NUMBER])
-AM_INIT_AUTOMAKE([silent-rules])
+AM_INIT_AUTOMAKE([silent-rules dist-xz])
AM_CONFIG_HEADER([config.h])
dnl Override automake's tar command used for creating distributions.
@@ -130,10 +130,16 @@ i\
0
q
'
+sed_extract_subminor='/^[0-9][0-9]*[.][0-9][0-9]*[.][0-9]/{s/^[0-9]*[.][0-9]*[.]\([0-9]*\).*/\1/p;q;}
+i\
+0
+q
+'
changequote([,])
version_major=`echo "${VERSION}" | sed -n -e "$sed_extract_major"`
version_minor=`echo "${VERSION}" | sed -n -e "$sed_extract_minor"`
-HEXVERSION=0x`$AWK 'BEGIN { printf("%02d%02d"',"$version_major","$version_minor"') }'`
+version_subminor=`echo "${VERSION}" | sed -n -e "$sed_extract_subminor"`
+HEXVERSION=0x`$AWK 'BEGIN { printf("%02X%02X%02X"',"$version_major","$version_minor","$version_subminor"') }'`
AC_SUBST([HEXVERSION])
dnl Check for tools needed for formatting the documentation.