summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2022-12-15 14:32:08 +0100
committerJörg Frings-Fürst <debian@jff.email>2022-12-15 14:32:08 +0100
commitbbb8e1d799ac3975a46ffa42a1dfc14bac43b1f1 (patch)
tree031381f6bc9aa14b3d68828e47f8cc2e242b4cfc /debian/rules
parent1b1ad4ed2919fbc68d8905cfec38a968821ce372 (diff)
parentf2b38304054892891dc053393b26a9c1406b42d4 (diff)
Merge branch 'release/debian/1.1-1_experimental2'debian/1.1-1_experimental2
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5a0855a..b34aa21 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,8 @@
# hardening
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+include /usr/share/dpkg/default.mk
+
ifneq ($(findstring $(DEB_BUILD_ARCH), mips mipsel),)
CFLAGS += -mplt
endif
@@ -22,4 +24,4 @@ VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-
override_dh_makeshlibs:
dh_makeshlibs
- dpkg-gensymbols -v$(VERSION) -plibunistring5
+ dpkg-gensymbols -v$(DEB_VERSION_UPSTREAM) -plibunistring5