summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am31
1 files changed, 11 insertions, 20 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 265ff46..ffbfae2 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,5 @@
## Makefile for the lib subdirectory of GNU libunistring.
-## Copyright (C) 2009-2011 Free Software Foundation, Inc.
+## Copyright (C) 2009-2010 Free Software Foundation, Inc.
##
## This program is free software: you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
@@ -20,7 +20,6 @@ AUTOMAKE_OPTIONS = 1.5 gnits subdir-objects no-dependencies
EXTRA_DIST =
BUILT_SOURCES =
MOSTLYCLEANFILES = core *.stackdump
-MOSTLYCLEANDIRS =
CLEANFILES =
DISTCLEANFILES =
MAINTAINERCLEANFILES =
@@ -36,7 +35,6 @@ nobase_include_HEADERS = \
uniname.h \
unictype.h \
uniwidth.h \
- unigbrk.h \
uniwbrk.h \
unilbrk.h \
uninorm.h \
@@ -159,7 +157,7 @@ nobase_nodist_include_HEADERS += unistring/version.h
# unistring/cdefs.h is not public, but is included by other header files.
nobase_nodist_include_HEADERS += unistring/cdefs.h
-unistring/cdefs.h : unistring/cdefs.in.h $(UNUSED_PARAMETER_H)
+unistring/cdefs.h : unistring/cdefs.in.h
@MKDIR_P@ unistring
rm -f $@-t $@
sed -e '/definition of _GL_UNUSED_PARAMETER/r $(UNUSED_PARAMETER_H)' \
@@ -201,7 +199,6 @@ HEADERS_WITH_EXTERNS = \
uniname.h \
unictype.h \
uniwidth.h \
- unigbrk.h \
uniwbrk.h \
unilbrk.h \
uninorm.h \
@@ -211,22 +208,15 @@ HEADERS_WITH_EXTERNS = \
unistring/version.in.h
# List of exported symbols.
-# We extract it from the header files that get installed.
-# We keep symbols that start with "_UC", because they may be needed for
-# compiling newer versions of gnulib modules when the gnulib module
-# 'libunistring-optional' is in use.
+# We extract it from the header files that get installed, removing symbols
+# start with "_UC".
# This file has the same format as the one expected by the libtool option
# '-export-symbols', but we don't use this option, because it would prevent us
# from building some of the gnulib unit tests.
libunistring.sym : $(HEADERS_WITH_EXTERNS)
- for f in $(HEADERS_WITH_EXTERNS); do \
- if test -f $$f; then \
- cat $$f; \
- else \
- cat $(srcdir)/$$f; \
- fi; \
- done \
+ for f in $(HEADERS_WITH_EXTERNS); do cat $(srcdir)/$$f; done \
| $(srcdir)/declared.sh | LC_ALL=C sort | LC_ALL=C uniq \
+ | grep -v '^_UC' \
> $@-t
mv $@-t $@
# We distribute it because declared.sh relies on GNU sed.
@@ -311,11 +301,12 @@ AM_CPPFLAGS += -DDEPENDS_ON_LIBICONV=1
# Libtool's library version information for libunistring.
# See the libtool documentation, section "Library interface versions".
-LTV_CURRENT=2
-LTV_REVISION=0
-LTV_AGE=0
+LTV_CURRENT=1
+LTV_REVISION=2
+LTV_AGE=1
# How to build libunistring.la.
libunistring_la_LDFLAGS += \
-version-info $(LTV_CURRENT):$(LTV_REVISION):$(LTV_AGE) \
- -rpath $(libdir)
+ -rpath $(libdir) \
+ @INTL_MACOSX_LIBS@ -no-undefined