summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Gonzalez Iniesta <agi@inittab.org>2013-06-20 13:29:18 +0200
committerAlberto Gonzalez Iniesta <agi@inittab.org>2013-06-20 13:29:18 +0200
commitb9780e6608daf26a31979204189ce7721f312b32 (patch)
tree7da31ed20d5d1832b7e6429ff68a33f8763ff00d
parent089e87c0c39240d5d82126cbf366bd621cfae6d0 (diff)
Use iproute2 in linux
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules6
3 files changed, 13 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index a2b4aea..883a441 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+openvpn (2.3.2-3) unstable; urgency=low
+
+ * Add iproute2 support on linux archs.
+ * Add versioned Build-Depends on dpkg-dev since --export=configure
+ is used. (Closes: #697560)
+
+ -- Alberto Gonzalez Iniesta <agi@inittab.org> Thu, 20 Jun 2013 13:23:24 +0200
+
openvpn (2.3.2-2) unstable; urgency=low
* Add pkg-config to Build-Depends while waiting for libpkcs11-helper1-dev's
diff --git a/debian/control b/debian/control
index fa20381..8c9b242 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,13 @@ Source: openvpn
Section: net
Priority: optional
Maintainer: Alberto Gonzalez Iniesta <agi@inittab.org>
-Build-Depends: debhelper (>= 7.0.50~), libssl-dev (>> 0.9.8g-9), liblzo2-dev, libpam0g-dev, libpkcs11-helper1-dev, net-tools, pkg-config
+Build-Depends: debhelper (>= 7.0.50~), libssl-dev (>> 0.9.8g-9), liblzo2-dev, libpam0g-dev, libpkcs11-helper1-dev, net-tools, pkg-config, dpkg-dev (>= 1.16.1)
Standards-Version: 3.9.3
Homepage: http://www.openvpn.net/
Package: openvpn
Architecture: any
-Depends: debconf | debconf-2.0, ${shlibs:Depends}, ${misc:Depends}, net-tools, initscripts (>= 2.88dsf-13.3)
+Depends: debconf | debconf-2.0, ${shlibs:Depends}, ${misc:Depends}, net-tools, initscripts (>= 2.88dsf-13.3), iproute [linux-any]
Suggests: openssl, resolvconf
Recommends: easy-rsa
Description: virtual private network daemon
diff --git a/debian/rules b/debian/rules
index 975881e..902b52b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,9 +2,9 @@
ifeq ($(DEB_HOST_ARCH_OS), kfreebsd)
# Avoid the /sbin/route wrapper which doesn't provide FreeBSD CLI as expected
-ROUTE_PATH := /lib/freebsd/route
+ROUTE_ARGS := --with-route-path=/lib/freebsd/route
else
-ROUTE_PATH := /sbin/route
+ROUTE_ARGS := --with-route-path=/sbin/route --with-iproute-path=/sbin/ip --enable-iproute2
endif
#export DH_VERBOSE=1
@@ -14,7 +14,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
dh $@
override_dh_auto_configure:
- dh_auto_configure -- $(shell dpkg-buildflags --export=configure) --enable-password-save --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --with-ifconfig-path=/sbin/ifconfig --with-route-path=$(ROUTE_PATH) --with-plugindir=\$${prefix}/lib/openvpn --includedir=\$${prefix}/include/openvpn --enable-pkcs11
+ dh_auto_configure -- $(shell dpkg-buildflags --export=configure) --enable-password-save --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --with-ifconfig-path=/sbin/ifconfig $(ROUTE_ARGS) --with-plugindir=\$${prefix}/lib/openvpn --includedir=\$${prefix}/include/openvpn --enable-pkcs11
override_dh_auto_build: