summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBernhard Schmidt <berni@debian.org>2020-04-19 15:52:38 +0200
committerBernhard Schmidt <berni@debian.org>2020-04-19 15:52:38 +0200
commit7728a9676dc67128c9adf56bc1d31a4e5b815b26 (patch)
treeae25e1ac822e848183a4e61eac8d5c53f520f128 /configure.ac
parentf90a78a23c77c840b764b0a95732f3ee3738ef99 (diff)
parent620785fe268a1221c1ba7a9cb5a70f3140a4f1ca (diff)
Update upstream source from tag 'upstream/2.4.9'
Update to upstream version '2.4.9' with Debian dir b64ac777b141e10bd0a11149a47506fd704401b8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 21 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e45ce2f..4690028 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1328,11 +1328,25 @@ if test "${enable_plugin_auth_pam}" = "yes"; then
fi
if test "${enable_async_push}" = "yes"; then
- AC_CHECK_HEADERS(
- [sys/inotify.h],
- AC_DEFINE([ENABLE_ASYNC_PUSH], [1], [Enable async push]),
- AC_MSG_ERROR([inotify.h not found.])
- )
+ case "$host" in
+ *-*-freebsd*)
+ PKG_CHECK_MODULES(
+ [OPTIONAL_INOTIFY],
+ [libinotify],
+ [
+ AC_DEFINE([HAVE_SYS_INOTIFY_H])
+ AC_DEFINE([ENABLE_ASYNC_PUSH], [1], [Enable async push])
+ ]
+ )
+ ;;
+ *)
+ AC_CHECK_HEADERS(
+ [sys/inotify.h],
+ AC_DEFINE([ENABLE_ASYNC_PUSH], [1], [Enable async push]),
+ AC_MSG_ERROR([inotify.h not found.])
+ )
+ ;;
+ esac
fi
CONFIGURE_DEFINES="`set | grep '^enable_.*=' ; set | grep '^with_.*='`"
@@ -1359,6 +1373,8 @@ AC_SUBST([OPTIONAL_LZ4_LIBS])
AC_SUBST([OPTIONAL_SYSTEMD_LIBS])
AC_SUBST([OPTIONAL_PKCS11_HELPER_CFLAGS])
AC_SUBST([OPTIONAL_PKCS11_HELPER_LIBS])
+AC_SUBST([OPTIONAL_INOTIFY_CFLAGS])
+AC_SUBST([OPTIONAL_INOTIFY_LIBS])
AC_SUBST([PLUGIN_AUTH_PAM_CFLAGS])
AC_SUBST([PLUGIN_AUTH_PAM_LIBS])