summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBernhard Schmidt <berni@debian.org>2019-03-07 21:38:56 +0100
committerBernhard Schmidt <berni@debian.org>2019-03-07 21:38:56 +0100
commitcfcec33bd88faeb354a33bd5f8052486ac848f9a (patch)
tree8e1ace9a34f5ee12b34416b02d514da67d54c907 /debian/rules
parent7486cf05cdeb6996fdf249e5a2f15d93a47dbac1 (diff)
parenta351f71e82badcc71a2ce881bbb97eccfcebc06b (diff)
Merge tag 'debian/2.4.7-1' into stretch-backports
openvpn Debian release 2.4.7-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 603d9a0..7bec9d2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
ifeq ($(DEB_HOST_ARCH_OS), kfreebsd)
# Avoid the /sbin/route wrapper which doesn't provide FreeBSD CLI as expected
ENV_VARS := IFCONFIG=/sbin/ifconfig ROUTE=/lib/freebsd/route
-EXTRA_ARGS :=
+EXTRA_ARGS :=
else
ENV_VARS := SYSTEMD_ASK_PASSWORD=/bin/systemd-ask-password IFCONFIG=/sbin/ifconfig ROUTE=/sbin/route IPROUTE=/sbin/ip SYSTEMD_UNIT_DIR=/lib/systemd/system TMPFILES_DIR=/usr/lib/tmpfiles.d
EXTRA_ARGS := --enable-systemd --enable-iproute2
@@ -52,7 +52,7 @@ override_dh_auto_install:
install -m 755 debian/openvpn.if-up.d $(CURDIR)/debian/openvpn/etc/network/if-up.d/openvpn
install -m 755 debian/openvpn.if-down.d $(CURDIR)/debian/openvpn/etc/network/if-down.d/openvpn
# remove unwanted plugin files
- rm -f $(CURDIR)/debian/openvpn/usr/lib/$(DEB_HOST_GNU_TYPE)/openvpn/plugins/*.la
+ $(RM) $(CURDIR)/debian/openvpn/usr/lib/$(DEB_HOST_GNU_TYPE)/openvpn/plugins/*.la
# resolvconf script
install -m 755 debian/update-resolv-conf $(CURDIR)/debian/openvpn/etc/openvpn/update-resolv-conf
# bash completion
@@ -61,14 +61,15 @@ override_dh_auto_install:
ifeq ($(DEB_HOST_ARCH_OS), linux)
cat debian/openvpn.conf >> $(CURDIR)/debian/openvpn/usr/lib/tmpfiles.d/openvpn.conf
endif
+ $(RM) $(CURDIR)/debian/openvpn/usr/share/doc/openvpn/COPYING
override_dh_installexamples:
dh_installexamples
## remove windoze stuff
- rm -rf $(CURDIR)/debian/openvpn/usr/share/doc/openvpn/examples/easy-rsa/Windows
- rm -rf $(CURDIR)/debian/openvpn/usr/share/doc/openvpn/sample
+ $(RM) -r $(CURDIR)/debian/openvpn/usr/share/doc/openvpn/examples/easy-rsa/Windows
+ $(RM) -r $(CURDIR)/debian/openvpn/usr/share/doc/openvpn/sample
# remove gitignore file from samples
- rm -f $(CURDIR)/debian/openvpn/usr/share/doc/openvpn/examples/sample-keys/.gitignore
+ $(RM) $(CURDIR)/debian/openvpn/usr/share/doc/openvpn/examples/sample-keys/.gitignore
override_dh_installinit:
dh_installinit --no-start -- defaults 16 80
@@ -76,6 +77,5 @@ override_dh_installinit:
override_dh_compress:
dh_compress --exclude=.cnf --exclude=pkitool
-override_dh_systemd_start:
- dh_systemd_start --restart-after-upgrade
-
+override_dh_installsystemd:
+ dh_installsystemd --restart-after-upgrade