summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c5d982d..ba759c2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@ endif
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
- dh $@
+ dh $@ --with systemd
override_dh_auto_configure:
dh_auto_configure -- $(shell dpkg-buildflags --export=configure) --enable-password-save --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --with-ifconfig-path=/sbin/ifconfig $(ROUTE_ARGS) --with-plugindir=\$${prefix}/lib/openvpn --includedir=\$${prefix}/include/openvpn --enable-pkcs11 --enable-x509-alt-username --enable-systemd
@@ -70,3 +70,6 @@ override_dh_installinit:
override_dh_compress:
dh_compress --exclude=.cnf --exclude=pkitool
+override_dh_systemd_start:
+ dh_systemd_start --restart-after-upgrade
+