summaryrefslogtreecommitdiff
path: root/distro/systemd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'distro/systemd/Makefile.am')
-rw-r--r--distro/systemd/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/distro/systemd/Makefile.am b/distro/systemd/Makefile.am
new file mode 100644
index 0000000..1e3f3ea
--- /dev/null
+++ b/distro/systemd/Makefile.am
@@ -0,0 +1,32 @@
+#
+# OpenVPN -- An application to securely tunnel IP networks
+# over a single UDP port, with support for SSL/TLS-based
+# session authentication and key exchange,
+# packet encryption, packet authentication, and
+# packet compression.
+#
+# Copyright (C) 2017 OpenVPN Technologies, Inc. <sales@openvpn.net>
+#
+
+%.service: %.service.in Makefile
+ $(AM_V_GEN)sed -e 's|\@sbindir\@|$(sbindir)|' \
+ $< > $@.tmp && mv $@.tmp $@
+
+EXTRA_DIST = \
+ tmpfiles-openvpn.conf \
+ openvpn-client@.service.in \
+ openvpn-server@.service.in
+
+if ENABLE_SYSTEMD
+systemdunit_DATA = \
+ openvpn-client@.service \
+ openvpn-server@.service
+tmpfiles_DATA = \
+ tmpfiles-openvpn.conf
+
+install-data-hook:
+ mv $(DESTDIR)$(tmpfilesdir)/tmpfiles-openvpn.conf $(DESTDIR)$(tmpfilesdir)/openvpn.conf
+endif
+
+MAINTAINERCLEANFILES = \
+ $(srcdir)/Makefile.in