summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b7980e0..e55928b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,12 +12,20 @@
MAINTAINERCLEANFILES = \
$(srcdir)/Makefile.in
-test_scripts = t_client.sh t_lpback.sh t_cltsrv.sh
+SUBDIRS = unit_tests
+
+test_scripts = t_client.sh
+if ENABLE_CRYPTO
+test_scripts += t_lpback.sh t_cltsrv.sh
+endif
TESTS_ENVIRONMENT = top_srcdir="$(top_srcdir)"
TESTS = $(test_scripts)
dist_noinst_SCRIPTS = \
$(test_scripts) \
- t_cltsrv-down.sh
+ t_cltsrv-down.sh \
+ update_t_client_ips.sh
+dist_noinst_DATA = \
+ t_client.rc-sample