summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-10-29 00:33:16 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-10-29 00:33:16 +0100
commitbc1363bd302ce6ec376d1204ebad56d951063078 (patch)
tree549ea386ff7876cab1d6ada67f7aeaf71abdff55
parent6ecc9f7c370a9c33692ec787c81a32c0e5795f8c (diff)
beautify d/rules, d/changelog
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules9
2 files changed, 6 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 6f26bea..b89daec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-psocksxx (0.0.6-3) unstable; urgency=low
+psocksxx (0.0.6-3) unstable; urgency=medium
* Make build results reproducible (Closes: #789399):
- New debian/patches/0700-ReproducibleBuilds.patch:
@@ -10,9 +10,9 @@ psocksxx (0.0.6-3) unstable; urgency=low
* debian/rules:
- Add override_dh_makeshlibs to remove the debian_revision for
dpkg-gensymbols.
- - Refresh symbol files (Closes: #802523).
+ - Refresh symbols files (Closes: #802523).
- -- Jörg Frings-Fürst <debian@jff-webhosting.net> Tue, 20 Oct 2015 23:58:27 +0200
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Fri, 23 Oct 2015 21:58:37 +0200
psocksxx (0.0.6-2) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index b6c8c00..b8258ef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,12 +9,13 @@
#
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
#
# add -Wall to compilerflags
#
export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS) -Wall
+UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -n '/\(Version:\)/{s/^Version:[[:space:]]\+\([0-9]\+:\)\?\(.*\)/\2/p}' | rev | cut -d- -f 2- | rev)
+
%:
dh $@ --with autoreconf
@@ -26,10 +27,6 @@ override_dh_installdocs-indep:
cp -r $(CURDIR)/doc/doxygen/html/* $(CURDIR)/debian/libpsocksxx-doc/usr/share/doc/libpsocksxx-doc/docs/
dh_installdocs
-UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -n '/\(Version:\)/{s/^Version:[[:space:]]\+\([0-9]\+:\)\?\(.*\)/\2/p}' | rev | cut -d- -f 2- | rev)
-
override_dh_makeshlibs:
dh_makeshlibs
- dpkg-gensymbols -c0 -v$(UPSTREAM_VERSION) -plibpsocksxx0
-
-
+ dpkg-gensymbols -v$(UPSTREAM_VERSION) -plibpsocksxx0