summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-10-03 07:05:57 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-10-03 07:05:57 +0200
commit20ee94cf87975b627e51f84ab6062193acd51745 (patch)
treead3055fe7ccb5c9fdddc710155dc51769ec10cb1 /debian/rules
parentf75243fd6a5c306f5ff9def56d27b667257110d6 (diff)
status form 2014-10-02
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 9 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 97d885b..f827959 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,19 +2,26 @@
# -*- makefile -*-
# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
#
# Hardening
#
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS) -Wall
+#CPPFLAGS+= -Wall
+#export CPPFLAGS
+
%:
dh $@ --with autoreconf
+override_dh_auto_build:
+ dh_auto_build
+ make -C doc doxygen-doc
override_dh_installdocs:
- make -C doc doxygen-doc
cp -r $(CURDIR)/doc/doxygen/html/* $(CURDIR)/debian/libpsocksxx-doc/usr/share/doc/libpsocksxx-doc/docs/
dh_installdocs