summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 4 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index f827959..bc5d38c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# -*- makefile -*-
# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
+#export DH_VERBOSE=1
#
# Hardening
@@ -10,9 +10,10 @@ export DH_VERBOSE=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#
+# add -Wall to compilerflags
+#
export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS) -Wall
-#CPPFLAGS+= -Wall
-#export CPPFLAGS
%:
dh $@ --with autoreconf
@@ -24,8 +25,3 @@ override_dh_auto_build:
override_dh_installdocs:
cp -r $(CURDIR)/doc/doxygen/html/* $(CURDIR)/debian/libpsocksxx-doc/usr/share/doc/libpsocksxx-doc/docs/
dh_installdocs
-
-override_dh_makeshlibs:
- dpkg-gensymbols -plibpsocksxx0
- dh_makeshlibs
-