summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..bc5d38c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+#
+# Hardening
+#
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+
+#
+# add -Wall to compilerflags
+#
+export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS) -Wall
+
+%:
+ dh $@ --with autoreconf
+
+override_dh_auto_build:
+ dh_auto_build
+ make -C doc doxygen-doc
+
+override_dh_installdocs:
+ cp -r $(CURDIR)/doc/doxygen/html/* $(CURDIR)/debian/libpsocksxx-doc/usr/share/doc/libpsocksxx-doc/docs/
+ dh_installdocs