summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-07-09 16:12:38 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-07-09 16:12:38 +0200
commit049849cac97ff5fa2e2b12503702fe52a115182c (patch)
tree74f51e477d942e83fafd4c555cf2e87a2ea758ab /debian/rules
parent89458660792bde178865362ddf6becf2f12aa8b6 (diff)
Use pkg-info.mk instead dpkg-parsechangelog
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 3 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 485f51b..fa62e71 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,14 @@
#!/usr/bin/make -f
+#export DH_VERBOSE=1
-DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
-VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[~-].*//')
-export DH_VERBOSE=1
+include /usr/share/dpkg/pkg-info.mk
%:
dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_configure:
- pod2man --section=1 --release=$(VERSION) --center "" doc/rapid-photo-downloader.1.pod > rapid-photo-downloader.1
+ pod2man --section=1 --release=$(DEB_SOURCE) --center "" doc/rapid-photo-downloader.1.pod > rapid-photo-downloader.1
#override_dh_auto_install:
# dh_auto_install -- --install-lib=/usr/share/rapid-photo-downloader --install-scripts=/usr/share/rapid-photo-downloader