summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-07-09 13:38:53 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-07-09 13:38:53 +0200
commit89458660792bde178865362ddf6becf2f12aa8b6 (patch)
treee138e6336364445b5e38d4f15f8bf339d1e8baf4 /debian/rules
parent14f84dc139317de4cfc02ff36c2ad799b060dbaf (diff)
Upgrade work
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 9 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index f1c848e..485f51b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,19 +3,21 @@
DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[~-].*//')
+export DH_VERBOSE=1
+
%:
- dh $@ --with python2
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_configure:
- pod2man --section=1 --release=$(VERSION) --center "" doc/rapid-photo-downloader.pod > rapid-photo-downloader.1
+ pod2man --section=1 --release=$(VERSION) --center "" doc/rapid-photo-downloader.1.pod > rapid-photo-downloader.1
-override_dh_auto_install:
- dh_auto_install -- --install-lib=/usr/share/rapid-photo-downloader --install-scripts=/usr/share/rapid-photo-downloader
+#override_dh_auto_install:
+# dh_auto_install -- --install-lib=/usr/share/rapid-photo-downloader --install-scripts=/usr/share/rapid-photo-downloader
override_dh_auto_clean:
- -rm rapid-photo-downloader.1
+# -rm rapid-photo-downloader.1
-rm -rf build/
- dh_auto_clean
+# dh_auto_clean
override_dh_installchangelogs:
- dh_installchangelogs rapid/ChangeLog
+ dh_installchangelogs CHANGES.rst