summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 9 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index f1c848e..485f51b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,19 +3,21 @@
DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[~-].*//')
+export DH_VERBOSE=1
+
%:
- dh $@ --with python2
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_configure:
- pod2man --section=1 --release=$(VERSION) --center "" doc/rapid-photo-downloader.pod > rapid-photo-downloader.1
+ pod2man --section=1 --release=$(VERSION) --center "" doc/rapid-photo-downloader.1.pod > rapid-photo-downloader.1
-override_dh_auto_install:
- dh_auto_install -- --install-lib=/usr/share/rapid-photo-downloader --install-scripts=/usr/share/rapid-photo-downloader
+#override_dh_auto_install:
+# dh_auto_install -- --install-lib=/usr/share/rapid-photo-downloader --install-scripts=/usr/share/rapid-photo-downloader
override_dh_auto_clean:
- -rm rapid-photo-downloader.1
+# -rm rapid-photo-downloader.1
-rm -rf build/
- dh_auto_clean
+# dh_auto_clean
override_dh_installchangelogs:
- dh_installchangelogs rapid/ChangeLog
+ dh_installchangelogs CHANGES.rst