summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-01-02 20:11:37 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-01-02 20:11:37 +0100
commit6023d0ffc729e956df760122594853ba6b3c4fa6 (patch)
treeeea93c0fcfe9a528bc8dd81a5b380b639e525d59
parent6edba82e9f5b807d8d5aecc4139a64a211cb1b4e (diff)
Add version string to dpkg-gensymbols
-rw-r--r--debian/changelog5
-rw-r--r--debian/copyright2
-rwxr-xr-xdebian/rules4
3 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index db40fff..4007c7f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,11 @@ sane-backends (1.0.24-9) UNRELEASED; urgency=medium
* Correct typo and add missing "-q" to line 33 of
debian/sane-utils.postinst (Closes: #773826).
- Thanks to "Nelson A. de Oliveira" <naoliv@debian.org>
+ * debian/rules:
+ - Add line to extract the version from debian/changelog.
+ - Add version string to dpkg-gensymbols.
+ * debian/copyright:
+ - Add years to 2014-2015 on my debian/* tag.
-- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 28 Dec 2014 10:50:14 +0100
diff --git a/debian/copyright b/debian/copyright
index 13aa9c7..f4bd25b 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -13,7 +13,7 @@ Copyright: 1997-2002 Kevin Dalley <kevind@rahul.net>
2002-2011 Julien BLACHE <jblache@debian.org>
2002-2006 Aurélien Jarno <aurel32@debian.org>
2013 Mark Buda <hermit@acm.org>
- 2014 Jörg Frings-Fürst <debian@jff-webhosting.net>
+ 2014-2015 Jörg Frings-Fürst <debian@jff-webhosting.net>
License: GPL-2+ with sane exception
Files: backend/abaton.*
diff --git a/debian/rules b/debian/rules
index 5fc4afb..3647468 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,6 +26,8 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
STRIP = ""
endif
+VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-/')
+
%:
dh $@ --parallel --with autotools_dev,systemd
@@ -137,5 +139,5 @@ override_dh_builddeb:
dh_builddeb -- -Zxz
override_dh_makeshlibs:
- dpkg-gensymbols -plibsane
+ dpkg-gensymbols -v$(VERSION) -plibsane
dh_makeshlibs