summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-10-26 19:23:28 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-10-26 19:23:28 +0100
commitadb914171df97557df9b8c373c2add2761720839 (patch)
tree5a44e1dcd83b315e4c0fc70533122ff78ed93540
parentd5af5e5b44d40be20cf0da5394ef8d5640b9eafa (diff)
work on bugs #629470, #736451, #743848, #766340
-rw-r--r--debian/changelog14
-rw-r--r--debian/control2
-rw-r--r--debian/patches/hp3900.patch20
-rw-r--r--debian/patches/niash_c-array-bounds.patch29
-rw-r--r--debian/patches/series3
-rw-r--r--debian/patches/typo.patch20
6 files changed, 86 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 940843b..a2f3fca 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,20 @@ sane-backends (1.0.24-4) UNRELEASED; urgency=medium
* debian/rules:
- Move the creation of /etc/sane.d/dll.d to libsane-common.
* Move libsane.(postrm|preinst) to libsane-common.* to handle
- in the right package.
+ in the right package. (Closes: #766340)
* Remose useless ( < "1.0.19-25" ) from libsane-common.preinst.
+ * debian/patches:
+ - New typo.patch:
+ + Correct typo in backend/gennesys.conf.in. (Closes: #743848)
+ Thanks to Jakub Wilk <jwilk@debian.org>.
+ - New hp3900.patch:
+ + Set startup gamma to the standalone default. (Closes: #629470)
+ Thanks to Peter Walser <pjw1965@gmail.com>.
+ - New niash_c-array-bounds.patch:
+ + Prevent array bounds in TScanner.
+ * debian/control:
+ - Change Build-Depends from the transitional package libgphoto2-2-dev
+ to libgphoto2-dev. (Closes: #736451)
-- Jörg Frings-Fürst <debian@jff-webhosting.net> Sat, 25 Oct 2014 09:34:09 +0200
diff --git a/debian/control b/debian/control
index 411ff1b..cb1f9c9 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,7 @@ Build-Depends:
gettext,
libavahi-client-dev,
libcam-dev [kfreebsd-any],
- libgphoto2-2-dev,
+ libgphoto2-dev,
libieee1284-3-dev [!hurd-i386],
libjpeg-dev,
libltdl3-dev,
diff --git a/debian/patches/hp3900.patch b/debian/patches/hp3900.patch
new file mode 100644
index 0000000..9504685
--- /dev/null
+++ b/debian/patches/hp3900.patch
@@ -0,0 +1,20 @@
+Description: Replace the startup gamma with the same from the standalone version
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=629470
+Forwarded: <URL|no|not-needed, useless if you have a Bug field, optional>
+Last-Update: 2014-10-26
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/backend/hp3900_sane.c
+===================================================================
+--- trunk.orig/backend/hp3900_sane.c
++++ trunk/backend/hp3900_sane.c
+@@ -1159,7 +1159,7 @@ options_init (TScanner * scanner)
+ TOptionValue *pVal;
+
+ /* set gamma */
+- gamma_create (scanner, 2.2);
++ gamma_create (scanner, 1.0);
+
+ /* color convertion */
+ scanner->cnv.colormode = -1;
diff --git a/debian/patches/niash_c-array-bounds.patch b/debian/patches/niash_c-array-bounds.patch
new file mode 100644
index 0000000..b7a2114
--- /dev/null
+++ b/debian/patches/niash_c-array-bounds.patch
@@ -0,0 +1,29 @@
+Description: prevent array bounds in TScanner
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Forwarded: <URL|no|not-needed, useless if you have a Bug field, optional>
+Last-Update: 2014-10-26
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/backend/niash.c
+===================================================================
+--- trunk.orig/backend/niash.c
++++ trunk/backend/niash.c
+@@ -64,6 +64,7 @@
+
+
+ /* options enumerator */
++/* on changes please check the typedef struct TScanner */
+ typedef enum
+ {
+ optCount = 0,
+@@ -105,8 +106,8 @@ typedef union
+
+ typedef struct
+ {
+- SANE_Option_Descriptor aOptions[optLast];
+- TOptionValue aValues[optLast];
++ SANE_Option_Descriptor aOptions[optGamma + 1];
++ TOptionValue aValues[optGamma + 1];
+
+ TScanParams ScanParams;
+ THWParams HWParams;
diff --git a/debian/patches/series b/debian/patches/series
index c92ae6a..4152836 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,6 @@
+niash_c-array-bounds.patch
+hp3900.patch
+typo.patch
license_typo.patch
man_typo.patch
dll_backend_conf.patch
diff --git a/debian/patches/typo.patch b/debian/patches/typo.patch
new file mode 100644
index 0000000..5201917
--- /dev/null
+++ b/debian/patches/typo.patch
@@ -0,0 +1,20 @@
+Description: typo in backend/genesys.conf.in
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743848
+Forwarded: <URL|no|not-needed, useless if you have a Bug field, optional>
+Last-Update: 2014-10-26
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/backend/genesys.conf.in
+===================================================================
+--- trunk.orig/backend/genesys.conf.in
++++ trunk/backend/genesys.conf.in
+@@ -2,7 +2,7 @@
+
+ #
+ # scanners that are not yet supported
+-# uncomment them only for developpment purpose
++# uncomment them only for development purpose
+ #
+
+ # UMAX Astra 4500 and Avision iVina 1600