summaryrefslogtreecommitdiff
path: root/frontend/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2021-02-16 18:25:42 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2021-02-16 18:25:42 +0100
commit64ddd1a4dfcefd11f662f5cf4bb05b590d901a97 (patch)
tree4303648095deff998ae20c2393b56db527742ac9 /frontend/Makefile.am
parent5793a221e112fa49073de0137d6bfa750a61b0a1 (diff)
parentecaaf250cb33ff61f37a7b441f2337584a655350 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'frontend/Makefile.am')
-rw-r--r--frontend/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/frontend/Makefile.am b/frontend/Makefile.am
index d27acf2..47c50f3 100644
--- a/frontend/Makefile.am
+++ b/frontend/Makefile.am
@@ -31,5 +31,18 @@ test_LDADD = ../lib/liblib.la ../backend/libsane.la
tstbackend_SOURCES = tstbackend.c
tstbackend_LDADD = ../lib/liblib.la ../backend/libsane.la
+if preloadable_backends_enabled
+if WITH_GENESYS_TESTS
+## Because the genesys backend is implemented in C++, programs need
+## to link against the standard C++ library. The work-around below
+## will work for the GNU C++ compiler with the GNU standard library
+## for C++. Other build scenarios may need work.
+scanimage_LDADD += -lstdc++
+saned_LDADD += -lstdc++
+test_LDADD += -lstdc++
+tstbackend_LDADD += -lstdc++
+endif
+endif
+
clean-local:
rm -f test tstbackend