summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 21 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e4150d..c54e939 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,12 +46,30 @@ dist_changelogs_DATA += ChangeLogs/ChangeLog-1.0.1
dist_changelogs_DATA += ChangeLogs/ChangeLog-1.0.0
EXTRA_DIST = .editorconfig
+EXTRA_DIST += INSTALL.linux
+EXTRA_DIST += autogen.sh
EXTRA_DIST += po/README
+# Just in case these come in handy during development started from a
+# regular source tarball. They are not needed otherwise as they are
+# already applied to the files in the source tarball.
+EXTRA_DIST += patches/ltmain.sh.patch
+EXTRA_DIST += patches/Rules-quot.patch
+EXTRA_DIST += patches/ax_create_stdint_h.19-20.m4.patch
+EXTRA_DIST += patches/ax_create_stdint_h.20-21.m4.patch
+
+EXTRA_DIST += tools/git-version-gen
+EXTRA_DIST += $(top_srcdir)/.version
+BUILT_SOURCES = $(top_srcdir)/.version
+
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
#
# Keep the .gitignore files sorted, and use this target to do it.
# Note that git's negated ignore patterns introduce order dependency
-# and should therefor be sorted with much more care than we do here.
+# and should therefore be sorted with much more care than we do here.
# Until that has been taken care of, such files are best left alone.
#
PERL=perl
@@ -91,12 +109,12 @@ libcheck:
fi
# Verify that backends do not contain any unwanted public symbols
-# anytime check or distcheck is ran.
+# anytime check or distcheck is run.
# TODO: Currently this doesn't pass. Uncomment once symbols have
# been cleaned up.
#check-am: libcheck
-# Run testsuite any time installcheck or distcheck is ran.
+# Run testsuite any time installcheck or distcheck is run.
# Must run testsuite after install or else shared library backends
# will not be found (including test backend).
installcheck-local: