summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 13 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index bf76154..6c8682a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,10 +2,9 @@ dnl Process this file with autoconf to produce a configure script.
dnl ******************************************************************
dnl Set up autoconf and automake
-dnl When preparing a release, modify the numeric version components
-dnl and remove the git suffix.
dnl ******************************************************************
-AC_INIT([sane-backends],m4_esyscmd_s([git describe --dirty]),
+AC_INIT([sane-backends],
+ m4_esyscmd_s([tools/git-version-gen --prefix '' .tarball-version]),
[sane-devel@alioth-lists.debian.net])
AC_PREREQ([2.69]) dnl minimum autoconf version required
AC_CONFIG_MACRO_DIR([m4])
@@ -13,10 +12,6 @@ AC_CONFIG_HEADERS([include/sane/config.h])
AM_INIT_AUTOMAKE([1.15 subdir-objects -Wall])
AM_SILENT_RULES
-dnl Turn off feature were automake will automatically run autoreconf.
-dnl This is because we used to check in generated files into CVS which
-dnl has known timestamp issues.
-AM_MAINTAINER_MODE
dnl ******************************************************************
dnl Determine SANE version components and release status
@@ -42,6 +37,7 @@ dnl ******************************************************************
AC_PROG_CC
AC_PROG_CXX
AM_PROG_CC_C_O
+AM_PATH_PYTHON(2.7)
sane_save_CC=$CC
AC_PROG_CC_C99 dnl enables extensions to ISO C99 :-(
AS_IF([test xno != "x$ac_cv_prog_cc_c99"],
@@ -72,7 +68,7 @@ dnl Checks for programs.
dnl ***********************************************************************
AC_PATH_PROG(SANE_CONFIG_PATH, sane-config, no)
-dnl Call explicitely before using PKG_*
+dnl Call explicitly before using PKG_*
PKG_PROG_PKG_CONFIG
AM_CONDITIONAL(CROSS_COMPILING, test x$cross_compiling = xyes)
@@ -105,7 +101,7 @@ AC_CHECK_LIB(m, sqrt, MATH_LIB="-lm")
AC_SUBST(MATH_LIB)
case ${host_os} in
os2*)
- AC_CHECK_LIB(syslog, sylog, SYSLOG_LIBS="-lsyslog")
+ AC_CHECK_LIB(syslog, syslog, SYSLOG_LIBS="-lsyslog")
;;
beos*)
AC_CHECK_LIB(be, syslog, SYSLOG_LIBS="-lbe")
@@ -589,7 +585,7 @@ AC_ARG_ENABLE(scsibuffersize,
[set_scsibuffersize="$enableval"], [set_scsibuffersize=131072])
AC_DEFINE_UNQUOTED(SCSIBUFFERSIZE, $set_scsibuffersize,
[SCSI command buffer size])
-dnl FIXME: Move tihs to configuration printout area but probably
+dnl FIXME: Move this to configuration printout area but probably
dnl but probably needs to be wrapped by what ever uses it so its
dnl only printed when used.
echo "scsi buffersize: $set_scsibuffersize"
@@ -608,7 +604,7 @@ dnl ****
dnl IPv6
dnl ****
-dnl check for IPv6 (can be overriden by --enable-ipv6)
+dnl check for IPv6 (can be overridden by --enable-ipv6)
if test "$ac_cv_func_getnameinfo" = "yes" \
&& test "$ac_cv_func_getaddrinfo" = "yes" ; then
SANE_CHECK_IPV6
@@ -633,8 +629,8 @@ esac
dnl Check for lock dir
AC_ARG_WITH(lockdir, AS_HELP_STRING([--with-lockdir=DIR],
- [set SANE lockdir @<:@localstatedir/lock/sane@:>@]),
- [locksanedir=$withval],[locksanedir=${localstatedir}/lock/sane])
+ [set SANE lockdir @<:@localstatedir/lock@:>@]),
+ [locksanedir=$withval],[locksanedir=${localstatedir}/lock])
AC_SUBST(locksanedir)
configdir="${sysconfdir}/sane.d"
@@ -721,11 +717,15 @@ for backend in ${BACKENDS} ; do
BACKEND_LIBS_ENABLED="${BACKEND_LIBS_ENABLED} libsane-${backend}.la"
BACKEND_CONFS_ENABLED="${BACKEND_CONFS_ENABLED} ${backend}.conf"
BACKEND_MANS_ENABLED="${BACKEND_MANS_ENABLED} sane-${backend}.5"
+ if test x$backend = xgenesys; then
+ with_genesys_tests=yes
+ fi
if test x$backend = xumax_pp; then
install_umax_pp_tools=yes
fi
done
AC_SUBST(BACKEND_LIBS_ENABLED)
+AM_CONDITIONAL(WITH_GENESYS_TESTS, test xyes = x$with_genesys_tests)
AM_CONDITIONAL(INSTALL_UMAX_PP_TOOLS, test xyes = x$install_umax_pp_tools)
AC_ARG_VAR(PRELOADABLE_BACKENDS, [list of backends to preload into single DLL])