summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0040-remove_git.patch2
-rw-r--r--debian/patches/0100-source_spelling.patch266
-rw-r--r--debian/patches/0125-multiarch_dll_search_path.patch11
-rw-r--r--debian/patches/0175-fix_tests.patch16
-rw-r--r--debian/patches/0605-fix_groff-warnings.patch48
-rw-r--r--debian/patches/series8
6 files changed, 206 insertions, 145 deletions
diff --git a/debian/patches/0040-remove_git.patch b/debian/patches/0040-remove_git.patch
index 2be7a6e..6cbe5f7 100644
--- a/debian/patches/0040-remove_git.patch
+++ b/debian/patches/0040-remove_git.patch
@@ -9,4 +9,4 @@ Index: trunk/.tarball-version
--- /dev/null
+++ trunk/.tarball-version
@@ -0,0 +1 @@
-+1.0.32-debian
++1.1.1-debian
diff --git a/debian/patches/0100-source_spelling.patch b/debian/patches/0100-source_spelling.patch
index 17bde04..6bf41f1 100644
--- a/debian/patches/0100-source_spelling.patch
+++ b/debian/patches/0100-source_spelling.patch
@@ -1,84 +1,194 @@
Description: Correct source typos
-Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Author: Jörg Frings-Fürst <debian@jff.email>
Forwarded: not-needed
-Last-Update: 2019-04-28
+Last-Update: 2022-02-04
----
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-Index: trunk/doc/sane-epjitsu.man
+Index: trunk/backend/epsonds-jpeg.c
===================================================================
---- trunk.orig/doc/sane-epjitsu.man
-+++ trunk/doc/sane-epjitsu.man
-@@ -42,7 +42,7 @@ Scanners can be specified in the configu
- .PP
- "usb 0x04c5 0x10c7" (or other vendor/product ids)
- .RS
--Requests backend to search all usb busses in the system for a device which uses that vendor and product id. The device will then be queried to determine if it is a supported scanner.
-+Requests backend to search all usb buses in the system for a device which uses that vendor and product id. The device will then be queried to determine if it is a supported scanner.
- .RE
- .PP
- "usb /dev/usb/scanner0" (or other device file)
-Index: trunk/backend/apple.c
-===================================================================
---- trunk.orig/backend/apple.c
-+++ trunk/backend/apple.c
-@@ -1546,7 +1546,7 @@ init_options (Apple_Scanner * s)
- /* Use volt_ref */
- s->opt[OPT_VOLT_REF].name = "volt-ref";
- s->opt[OPT_VOLT_REF].title = "Volt Reference";
-- s->opt[OPT_VOLT_REF].desc ="It's brightness equivalant.";
-+ s->opt[OPT_VOLT_REF].desc ="It's brightness equivalent.";
- s->opt[OPT_VOLT_REF].type = SANE_TYPE_BOOL;
- if (s->hw->ScannerModel!=COLORONESCANNER)
- s->opt[OPT_VOLT_REF].cap |= SANE_CAP_INACTIVE;
-Index: trunk/tools/umax_pp.c
-===================================================================
---- trunk.orig/tools/umax_pp.c
-+++ trunk/tools/umax_pp.c
-@@ -374,10 +374,10 @@ main (int argc, char **argv)
- if (sanei_umax_pp_initPort (port, name) != 1)
- {
- if (port)
-- fprintf (stderr, "failed to gain direct acces to port 0x%X!\n",
-+ fprintf (stderr, "failed to gain direct access to port 0x%X!\n",
- port);
- else
-- fprintf (stderr, "failed to gain acces to device %s!\n", name);
-+ fprintf (stderr, "failed to gain access to device %s!\n", name);
- return 0;
- }
- }
-Index: trunk/doc/saned.man
-===================================================================
---- trunk.orig/doc/saned.man
-+++ trunk/doc/saned.man
-@@ -254,7 +254,7 @@ to the systemd journal. The systemd supp
- requires compilation with the systemd-devel package
- installed on the system. this is the preferred option.
-
--Saned can be used wih systemd without the systemd integration
-+Saned can be used with systemd without the systemd integration
- compiled in, but then logging of debug information is not supported.
-
- The systemd configuration is different for the 2 options, so
-Index: trunk/doc/sane-pixma.man
+--- trunk.orig/backend/epsonds-jpeg.c
++++ trunk/backend/epsonds-jpeg.c
+@@ -194,7 +194,7 @@ void eds_decode_jpeg(epsonds_scanner*s,
+ }
+ }
+ }
+- DBG(10,"decodded lines = %d\n", sum);
++ DBG(10,"decoded lines = %d\n", sum);
+
+ // abandon unncessary data
+ if ((JDIMENSION)sum < jpeg_cinfo.output_height)
+Index: trunk/frontend/jpegtopdf.c
===================================================================
---- trunk.orig/doc/sane-pixma.man
-+++ trunk/doc/sane-pixma.man
-@@ -328,7 +328,7 @@ This will cause all further statements i
- .IP -
- A line that contains
- .B auto_detection=no
--will cause auto-detection to be skipped. Explicitely defined network scanners will still be probed.
-+will cause auto-detection to be skipped. Explicitly defined network scanners will still be probed.
- .SH USB SUPPORT
- USB scanners will be auto-detected and require no configuration.
- .SH NETWORKING SUPPORT
-@@ -358,7 +358,7 @@ common subnet for scanning.
- .PP
- Scanner detection is slightly more complicated. The pixma backend sends
- a broadcast on all direct connected subnets it can find (provided your OS
--allows for enumeration of all netowrk interfaces). The broadcast is sent FROM
-+allows for enumeration of all network interfaces). The broadcast is sent FROM
- port 8612 TO port 8610 or 8612 on the broadcast address of each interface.
- The outgoing packets will be allowed by the rule described above.
- .PP
+--- trunk.orig/frontend/jpegtopdf.c
++++ trunk/frontend/jpegtopdf.c
+@@ -285,7 +285,7 @@ SANE_Int sane_pdf_start_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -326,7 +326,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -346,7 +346,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -360,7 +360,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -376,7 +376,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -386,7 +386,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( _get_current_time( &tm, &sign_c, &tz_h, &tz_m ) == SANE_ERR ) {
+- fprintf ( stderr, " Error is occured in _get_current_time.\n" );
++ fprintf ( stderr, " Error is occurred in _get_current_time.\n" );
+ goto EXIT;
+ }
+ /* Dates format */
+@@ -404,7 +404,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -420,7 +420,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -434,7 +434,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+ w_count += SANE_PDF_FIRST_PAGE_ID - 1;
+@@ -450,7 +450,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+ w_count ++;
+@@ -472,7 +472,7 @@ SANE_Int sane_pdf_end_doc( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -568,7 +568,7 @@ SANE_Int sane_pdf_start_page(
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -586,7 +586,7 @@ SANE_Int sane_pdf_start_page(
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+ /* write Contents(2) */
+@@ -598,7 +598,7 @@ SANE_Int sane_pdf_start_page(
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -609,7 +609,7 @@ SANE_Int sane_pdf_start_page(
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -627,7 +627,7 @@ SANE_Int sane_pdf_start_page(
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -648,7 +648,7 @@ SANE_Int sane_pdf_start_page(
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -680,7 +680,7 @@ SANE_Int sane_pdf_end_page( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
+@@ -698,7 +698,7 @@ SANE_Int sane_pdf_end_page( void *pw )
+ goto EXIT;
+ }
+ if ( ( ldata = re_write_if_fail( pwork->fd, str, len ) ) < 0 ) {
+- fprintf ( stderr, " Error is occured in re_write_if_fail.\n" );
++ fprintf ( stderr, " Error is occurred in re_write_if_fail.\n" );
+ goto EXIT;
+ }
+
diff --git a/debian/patches/0125-multiarch_dll_search_path.patch b/debian/patches/0125-multiarch_dll_search_path.patch
index 25726c7..67b9484 100644
--- a/debian/patches/0125-multiarch_dll_search_path.patch
+++ b/debian/patches/0125-multiarch_dll_search_path.patch
@@ -7,7 +7,7 @@ Index: trunk/backend/dll.c
===================================================================
--- trunk.orig/backend/dll.c
+++ trunk/backend/dll.c
-@@ -470,7 +470,7 @@ load (struct backend *be)
+@@ -468,18 +468,18 @@ load (struct backend *be)
if (path)
{
@@ -16,10 +16,9 @@ Index: trunk/backend/dll.c
src = malloc (src_len);
if (!src)
{
-@@ -480,11 +480,11 @@ load (struct backend *be)
- if (orig_src)
- free (orig_src);
- orig_src = src;
+ DBG (1, "load: malloc failed: %s\n", strerror (errno));
+ return SANE_STATUS_NO_MEM;
+ }
- snprintf (src, src_len, "%s%s%s", path, DIR_SEP, LIBDIR);
+ snprintf (src, src_len, "%s%s%s", path, DIR_SEP, DEB_DLL_LIBDIR);
}
@@ -34,7 +33,7 @@ Index: trunk/backend/Makefile.am
===================================================================
--- trunk.orig/backend/Makefile.am
+++ trunk/backend/Makefile.am
-@@ -4,7 +4,7 @@
+@@ -5,7 +5,7 @@
## This file is part of the "Sane" build infra-structure. See
## included LICENSE file for license information.
diff --git a/debian/patches/0175-fix_tests.patch b/debian/patches/0175-fix_tests.patch
index 77f5e03..612d851 100644
--- a/debian/patches/0175-fix_tests.patch
+++ b/debian/patches/0175-fix_tests.patch
@@ -11,7 +11,7 @@ Index: trunk/testsuite/tools/data/db.ref
@@ -1,5 +1,5 @@
# This file was generated from description files (*.desc)
-# by sane-desc 3.6 from sane-backends 1.0.29-241-g1f9590ab
-+# by sane-desc 3.6 from sane-backends 1.0.32-debian
++# by sane-desc 3.6 from sane-backends 1.1.1-debian
#
# The entries below are used to detect a USB device when it's plugged in
# and then run a script to change the ownership and
@@ -24,7 +24,7 @@ Index: trunk/testsuite/tools/data/html-backends-split.ref
</address>
<font size=-1>
-This page was created by sane-desc 3.6 from sane-backends 1.0.29-241-g1f9590ab
-+This page was created by sane-desc 3.6 from sane-backends 1.0.32-debian
++This page was created by sane-desc 3.6 from sane-backends 1.1.1-debian
</font>
</body> </html>
Index: trunk/testsuite/tools/data/html-mfgs.ref
@@ -36,7 +36,7 @@ Index: trunk/testsuite/tools/data/html-mfgs.ref
</address>
<font size=-1>
-This page was created by sane-desc 3.6 from sane-backends 1.0.29-241-g1f9590ab
-+This page was created by sane-desc 3.6 from sane-backends 1.0.32-debian
++This page was created by sane-desc 3.6 from sane-backends 1.1.1-debian
</font>
</body> </html>
Index: trunk/testsuite/tools/data/hwdb.ref
@@ -46,7 +46,7 @@ Index: trunk/testsuite/tools/data/hwdb.ref
@@ -1,5 +1,5 @@
# This file was generated from description files (*.desc)
-# by sane-desc 3.6 from sane-backends 1.0.29-241-g1f9590ab
-+# by sane-desc 3.6 from sane-backends 1.0.32-debian
++# by sane-desc 3.6 from sane-backends 1.1.1-debian
#
# hwdb file for supported USB devices
#
@@ -57,7 +57,7 @@ Index: trunk/testsuite/tools/data/udev+acl.ref
@@ -1,5 +1,5 @@
# This file was generated from description files (*.desc)
-# by sane-desc 3.6 from sane-backends 1.0.31-118-g5d3ce7806
-+# by sane-desc 3.6 from sane-backends 1.0.32-debian
++# by sane-desc 3.6 from sane-backends 1.1.1-debian
#
# udev rules file for supported USB and SCSI devices
#
@@ -68,7 +68,7 @@ Index: trunk/testsuite/tools/data/udev+hwdb.ref
@@ -1,5 +1,5 @@
# This file was generated from description files (*.desc)
-# by sane-desc 3.6 from sane-backends 1.0.29-241-g1f9590ab
-+# by sane-desc 3.6 from sane-backends 1.0.32-debian
++# by sane-desc 3.6 from sane-backends 1.1.1-debian
#
# udev rules file for supported USB and SCSI devices
#
@@ -79,7 +79,7 @@ Index: trunk/testsuite/tools/data/udev.ref
@@ -1,5 +1,5 @@
# This file was generated from description files (*.desc)
-# by sane-desc 3.6 from sane-backends 1.0.31-118-g5d3ce7806
-+# by sane-desc 3.6 from sane-backends 1.0.32-debian
++# by sane-desc 3.6 from sane-backends 1.1.1-debian
#
# udev rules file for supported USB and SCSI devices
#
@@ -90,7 +90,7 @@ Index: trunk/testsuite/tools/data/usermap.ref
@@ -1,5 +1,5 @@
# This file was generated from description files (*.desc)
-# by sane-desc 3.6 from sane-backends 1.0.29-241-g1f9590ab
-+# by sane-desc 3.6 from sane-backends 1.0.32-debian
++# by sane-desc 3.6 from sane-backends 1.1.1-debian
#
# The entries below are used to detect a USB device and change owner
# and permissions on the "device node" used by libusb.
diff --git a/debian/patches/0605-fix_groff-warnings.patch b/debian/patches/0605-fix_groff-warnings.patch
index 9e8ecde..1e0ac17 100644
--- a/debian/patches/0605-fix_groff-warnings.patch
+++ b/debian/patches/0605-fix_groff-warnings.patch
@@ -4,54 +4,6 @@ Bug: https://gitlab.com/sane-project/backends/-/issues/433
Last-Update: 2021-02-17
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-Index: trunk/doc/sane-canon_dr.man
-===================================================================
---- trunk.orig/doc/sane-canon_dr.man
-+++ trunk/doc/sane-canon_dr.man
-@@ -161,7 +161,7 @@ Some scanners pad the upper edge of one
- .RE
- .PP
- .BR NOTE :
--'option' lines may appear multiple times in the configuration file.
-+"option" lines may appear multiple times in the configuration file.
- They only apply to scanners discovered by the next 'scsi/usb' line.
- .PP
-
-Index: trunk/doc/sane-pixma.man
-===================================================================
---- trunk.orig/doc/sane-pixma.man
-+++ trunk/doc/sane-pixma.man
-@@ -184,7 +184,7 @@ an up-to-date status at the project home
- Users feedback is essential to help improve features and performances.
- .SH OPTIONS
- Besides "well-known" options (e.g. resolution, mode etc.)
--.Bsane\-pixma
-+.B sane\-pixma
- backend also
- provides the following options, i.e. the options might change in the future.
- .br
-Index: trunk/doc/sane-scsi.man
-===================================================================
---- trunk.orig/doc/sane-scsi.man
-+++ trunk/doc/sane-scsi.man
-@@ -122,7 +122,7 @@ $ chmod 660 /dev/sg0
- .RE
- .PP
- When your system uses the device filesystem (devfs), you have to edit
--.BIR /etc/devfs/perms.
-+.BI /etc/devfs/perms.
- There you should search the line
- .PP
- .RS
-@@ -172,7 +172,7 @@ If there are no
- devices, just do a
- .I sh MAKEDEV uk0
- in the
--.i /dev
-+.I /dev
- directory. The scanner should then be accessible as
- .I /dev/uk0
- if it was probed during boot.
Index: trunk/doc/sane-artec_eplus48u.man
===================================================================
--- trunk.orig/doc/sane-artec_eplus48u.man
diff --git a/debian/patches/series b/debian/patches/series
index 2a4677c..a1dd4c2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,11 +1,11 @@
0035-trim-libraries-in-sane-backends.pc.in.patch
0040-remove_git.patch
-#0100-source_spelling.patch
-#0125-multiarch_dll_search_path.patch
+0100-source_spelling.patch
+0125-multiarch_dll_search_path.patch
0175-fix_tests.patch
0140-avahi.patch
0145-avahi.patch
-0600-scanimage_manpage.patch
+#0600-scanimage_manpage.patch
0705-kfreebsd.patch
0725-fix_link_60-libsane_rule.patch
0150-i386-test.patch
@@ -17,4 +17,4 @@
#0165-respect_local_only_parameter.patch
#0170-return_empty_list_when_local_devices_requested.patch
0605-fix_groff-warnings.patch
-0180-gt68xx_fix_use-after-free_two_memleaks.patch
+#0180-gt68xx_fix_use-after-free_two_memleaks.patch