summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5fc4afb..846dcad 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,7 @@ DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
ifeq ($(DEB_HOST_ARCH_OS),)
DEB_HOST_ARCH_OS := $(subst -gnu,,$(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM))
ifeq ($(DEB_HOST_ARCH_OS),gnu)
@@ -26,6 +27,8 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
STRIP = ""
endif
+VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/+.*).*//;s/\+/\-/')
+
%:
dh $@ --parallel --with autotools_dev,systemd
@@ -137,5 +140,5 @@ override_dh_builddeb:
dh_builddeb -- -Zxz
override_dh_makeshlibs:
- dpkg-gensymbols -plibsane
+ dpkg-gensymbols -v$(VERSION) -plibsane
dh_makeshlibs