summaryrefslogtreecommitdiff
path: root/frontend/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'frontend/Makefile.am')
-rw-r--r--frontend/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/frontend/Makefile.am b/frontend/Makefile.am
new file mode 100644
index 0000000..a501931
--- /dev/null
+++ b/frontend/Makefile.am
@@ -0,0 +1,34 @@
+## Makefile.am -- an automake template for Makefile.in file
+## Copyright (C) 2009 Chris Bagwell and Sane Developers.
+##
+## This file is part of the "Sane" build infra-structure. See
+## included LICENSE file for license information.
+
+EXTRA_PROGRAMS = test tstbackend
+
+bin_PROGRAMS = scanimage
+
+if COMPILE_SANED
+sbin_PROGRAMS = saned
+else
+EXTRA_PROGRAMS += saned
+endif
+
+AM_CPPFLAGS = -I. -I$(srcdir) -I$(top_builddir)/include -I$(top_srcdir)/include
+
+scanimage_SOURCES = scanimage.c stiff.c stiff.h
+scanimage_LDADD = ../backend/libsane.la ../sanei/libsanei.la ../lib/liblib.la \
+ ../lib/libfelib.la
+
+saned_SOURCES = saned.c
+saned_LDADD = ../backend/libsane.la ../sanei/libsanei.la ../lib/liblib.la \
+ ../lib/libfelib.la @SYSLOG_LIBS@ @SYSTEMD_LIBS@
+
+test_SOURCES = test.c
+test_LDADD = ../lib/liblib.la ../lib/libfelib.la ../backend/libsane.la
+
+tstbackend_SOURCES = tstbackend.c
+tstbackend_LDADD = ../lib/liblib.la ../lib/libfelib.la ../backend/libsane.la
+
+clean-local:
+ rm -f test tstbackend