summaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
index 9e9eac7..01282d4 100644
--- a/testsuite/Makefile.am
+++ b/testsuite/Makefile.am
@@ -4,7 +4,7 @@
## This file is part of the "Sane" build infra-structure. See
## included LICENSE file for license information.
-SUBDIRS = sanei tools
+SUBDIRS = backend sanei tools
SCANIMAGE = ../frontend/scanimage$(EXEEXT)
TESTFILE = $(srcdir)/testfile.pnm
@@ -22,21 +22,21 @@ help:
test: test.local
-test.local:
+test.local:
@echo "**** Testing $(SCANIMAGE) with device $(DEVICE)"
@if echo "---> Trying flatbed scanner" && \
$(SCANIMAGE) -d $(DEVICE) -T && \
- echo "<--- Flatbed scanner succeded" && \
+ echo "<--- Flatbed scanner succeeded" && \
echo "---> Trying three pass flatbed scanner" && \
$(SCANIMAGE) -d $(DEVICE) --mode Color --three-pass=yes -T && \
- echo "<--- Three pass scanner succeded" && \
+ echo "<--- Three pass scanner succeeded" && \
echo "---> Trying hand scanner" && \
$(SCANIMAGE) -d $(DEVICE) --hand-scanner=yes -T && \
- echo "<--- Hand scanner succeded" && \
+ echo "<--- Hand scanner succeeded" && \
echo "---> Checking 16 bit color mode" && \
$(SCANIMAGE) -d $(DEVICE) $(OPTIONS) && \
cmp -s $(TESTFILE) $(OUTFILE) && \
- echo "<--- 16 bit color mode succeded" && \
+ echo "<--- 16 bit color mode succeeded" && \
rm $(OUTFILE) ; \
then echo ; echo ; echo "**** All tests passed" ; \
else echo ; echo; \