summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-16 06:58:13 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-16 06:58:13 +0100
commite20c9557371eacec533588d33b4bebd543ba178f (patch)
treed48d297298e410a3068d647c95f2d06e635015b8 /bin
parentf681a1fb71c146c754f57508afac240d0e1b47e1 (diff)
Imported Upstream version 2.4.1upstream/2.4.1
Diffstat (limited to 'bin')
-rw-r--r--bin/docs-create-example-outputs.py2
-rw-r--r--bin/docs-validate.py1
-rw-r--r--bin/import-test.py2
-rw-r--r--bin/linecount.py2
-rw-r--r--bin/restore.sh20
-rw-r--r--bin/update-release-info.py3
6 files changed, 16 insertions, 14 deletions
diff --git a/bin/docs-create-example-outputs.py b/bin/docs-create-example-outputs.py
index 30dc0ee..6e59d9f 100644
--- a/bin/docs-create-example-outputs.py
+++ b/bin/docs-create-example-outputs.py
@@ -14,6 +14,6 @@ if __name__ == "__main__":
print "OK"
else:
print "Not all example names and suffixes are unique! Please correct the errors listed above and try again."
- sys.exit(0)
+ sys.exit(1)
SConsExamples.createAllExampleOutputs(os.path.join('doc','user'))
diff --git a/bin/docs-validate.py b/bin/docs-validate.py
index c445c3f..f888c21 100644
--- a/bin/docs-validate.py
+++ b/bin/docs-validate.py
@@ -25,3 +25,4 @@ if __name__ == "__main__":
print "OK"
else:
print "Validation failed! Please correct the errors above and try again."
+ sys.exit(1)
diff --git a/bin/import-test.py b/bin/import-test.py
index b1f0efa..93f1c62 100644
--- a/bin/import-test.py
+++ b/bin/import-test.py
@@ -25,7 +25,7 @@
# """ triple-quotes will need to have their contents edited by hand.
#
-__revision__ = "bin/import-test.py rel_2.4.0:3365:9259ea1c13d7 2015/09/21 14:03:43 bdbaddog"
+__revision__ = "bin/import-test.py rel_2.4.1:3453:73fefd3ea0b0 2015/11/09 03:25:05 bdbaddog"
import os.path
import sys
diff --git a/bin/linecount.py b/bin/linecount.py
index 84173fe..5b17780 100644
--- a/bin/linecount.py
+++ b/bin/linecount.py
@@ -23,7 +23,7 @@
# interesting one for most purposes.
from __future__ import division
-__revision__ = "bin/linecount.py rel_2.4.0:3365:9259ea1c13d7 2015/09/21 14:03:43 bdbaddog"
+__revision__ = "bin/linecount.py rel_2.4.1:3453:73fefd3ea0b0 2015/11/09 03:25:05 bdbaddog"
import os.path
diff --git a/bin/restore.sh b/bin/restore.sh
index d5258b5..c393b00 100644
--- a/bin/restore.sh
+++ b/bin/restore.sh
@@ -1,6 +1,6 @@
#!/usr/bin/env sh
#
-# Simple hack script to restore __revision__, __COPYRIGHT_, 2.4.0
+# Simple hack script to restore __revision__, __COPYRIGHT_, 2.4.1
# and other similar variables to what gets checked in to source. This
# comes in handy when people send in diffs based on the released source.
#
@@ -24,7 +24,7 @@ for i in `find $DIRS -name '*.py'`; do
ed $i <<EOF
g/Copyright (c) 2001.*SCons Foundation/s//Copyright (c) 2001 - 2015 The SCons Foundation/p
w
-/^__revision__ = /s/= .*/= "bin/restore.sh rel_2.4.0:3365:9259ea1c13d7 2015/09/21 14:03:43 bdbaddog"/p
+/^__revision__ = /s/= .*/= "bin/restore.sh rel_2.4.1:3453:73fefd3ea0b0 2015/11/09 03:25:05 bdbaddog"/p
w
q
EOF
@@ -35,7 +35,7 @@ for i in `find $DIRS -name 'scons.bat'`; do
ed $i <<EOF
g/Copyright (c) 2001.*SCons Foundation/s//Copyright (c) 2001 - 2015 The SCons Foundation/p
w
-/^@REM src\/script\/scons.bat/s/@REM .* knight/@REM bin/restore.sh rel_2.4.0:3365:9259ea1c13d7 2015/09/21 14:03:43 bdbaddog/p
+/^@REM src\/script\/scons.bat/s/@REM .* knight/@REM bin/restore.sh rel_2.4.1:3453:73fefd3ea0b0 2015/11/09 03:25:05 bdbaddog/p
w
q
EOF
@@ -44,13 +44,13 @@ done
for i in `find $DIRS -name '__init__.py' -o -name 'scons.py' -o -name 'sconsign.py'`; do
header $i
ed $i <<EOF
-/^__version__ = /s/= .*/= "2.4.0"/p
+/^__version__ = /s/= .*/= "2.4.1"/p
w
-/^__build__ = /s/= .*/= "rel_2.4.0:3365:9259ea1c13d7"/p
+/^__build__ = /s/= .*/= "rel_2.4.1:3453:73fefd3ea0b0"/p
w
-/^__buildsys__ = /s/= .*/= "hpmicrodog"/p
+/^__buildsys__ = /s/= .*/= "ubuntu1404-32bit"/p
w
-/^__date__ = /s/= .*/= "2015/09/21 14:03:43"/p
+/^__date__ = /s/= .*/= "2015/11/09 03:25:05"/p
w
/^__developer__ = /s/= .*/= "bdbaddog"/p
w
@@ -61,7 +61,7 @@ done
for i in `find $DIRS -name 'setup.py'`; do
header $i
ed $i <<EOF
-/^ *version = /s/= .*/= "2.4.0",/p
+/^ *version = /s/= .*/= "2.4.1",/p
w
q
EOF
@@ -72,9 +72,9 @@ for i in `find $DIRS -name '*.txt'`; do
ed $i <<EOF
g/Copyright (c) 2001.*SCons Foundation/s//Copyright (c) 2001 - 2015 The SCons Foundation/p
w
-/# [^ ]* 0.96.[CD][0-9]* [0-9\/]* [0-9:]* knight$/s/.*/# bin/restore.sh rel_2.4.0:3365:9259ea1c13d7 2015/09/21 14:03:43 bdbaddog/p
+/# [^ ]* 0.96.[CD][0-9]* [0-9\/]* [0-9:]* knight$/s/.*/# bin/restore.sh rel_2.4.1:3453:73fefd3ea0b0 2015/11/09 03:25:05 bdbaddog/p
w
-/Version [0-9][0-9]*\.[0-9][0-9]*/s//Version 2.4.0/p
+/Version [0-9][0-9]*\.[0-9][0-9]*/s//Version 2.4.1/p
w
q
EOF
diff --git a/bin/update-release-info.py b/bin/update-release-info.py
index 45b1bdf..510440d 100644
--- a/bin/update-release-info.py
+++ b/bin/update-release-info.py
@@ -57,7 +57,7 @@ In 'post' mode, files are prepared for the next release cycle:
# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-__revision__ = "bin/update-release-info.py rel_2.4.0:3365:9259ea1c13d7 2015/09/21 14:03:43 bdbaddog"
+__revision__ = "bin/update-release-info.py rel_2.4.1:3453:73fefd3ea0b0 2015/11/09 03:25:05 bdbaddog"
import os
import sys
@@ -295,6 +295,7 @@ t = UpdateFile(os.path.join('src', 'Announce.txt'))
if DEBUG: t.file = '/tmp/Announce.txt'
t.sub('\nRELEASE .*', '\nRELEASE ' + version_string + ' - ' + t.new_date)
+
# Update SConstruct
t = UpdateFile('SConstruct')