summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLuca Falavigna <dktrkranz@debian.org>2009-09-08 22:32:46 +0200
committerLuca Falavigna <dktrkranz@debian.org>2009-09-08 22:32:46 +0200
commit8c10e4a4bef26dec711554dfe8bad5b99dd3661f (patch)
tree8eff6e6363b6f615873fa6b90665df2eb3d5f95b /debian/rules
parent5f06f160ac64f3a0acb67826d49f36b718a4dcd5 (diff)
Switch to debhelper 7
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules44
1 files changed, 7 insertions, 37 deletions
diff --git a/debian/rules b/debian/rules
index ba3e26a..99733cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,42 +1,12 @@
#!/usr/bin/make -f
-VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-/')
+%:
+ dh $@
-build: build-stamp
-build-stamp:
- dh_testdir
- db2html -o ${CURDIR}/user doc/user/main.xml || true
- db2html -o ${CURDIR}/user -u doc/user/main.xml || true
- touch $@
+override_dh_auto_clean:
+ scons -c
+ rm -fr build
-clean:
- dh_testdir
- dh_testroot
- rm -fr build-stamp docbook2html-dir user
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
-binary-indep: install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installchangelogs
- dh_link usr/share/doc/scons-doc/user/main.html usr/share/doc/scons-doc/user.html
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary-arch: install
-
-binary: binary-indep binary-arch
-
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_install:
+ scons doc