diff options
author | Luca Falavigna <dktrkranz@debian.org> | 2010-01-23 15:22:02 +0100 |
---|---|---|
committer | Luca Falavigna <dktrkranz@debian.org> | 2010-01-23 15:22:02 +0100 |
commit | 48f19e9e5ecc069f379ad433fdaf280ac9b54e16 (patch) | |
tree | ccb7df7851740465e630eeda7f618e66d1f86f53 /src/script | |
parent | 72c578fd4b0b4a5a43e18594339ac4ff26c376dc (diff) |
Imported Upstream version 1.2.0.d20100117upstream/1.2.0.d20100117
Diffstat (limited to 'src/script')
-rw-r--r-- | src/script/README.txt | 6 | ||||
-rw-r--r-- | src/script/scons-post-install.py | 4 | ||||
-rw-r--r-- | src/script/scons-time.py | 4 | ||||
-rw-r--r-- | src/script/scons.bat | 8 | ||||
-rw-r--r-- | src/script/scons.py | 10 | ||||
-rw-r--r-- | src/script/sconsign.py | 10 | ||||
-rw-r--r-- | src/script/setup.py | 6 |
7 files changed, 24 insertions, 24 deletions
diff --git a/src/script/README.txt b/src/script/README.txt index 0060819..d841b26 100644 --- a/src/script/README.txt +++ b/src/script/README.txt @@ -4,13 +4,13 @@ ### SCHEME. WE'RE SAVING THIS IN CASE WE NEED OR WANT TO RESURRECT ### A SEPARATE SCRIPT PACKAGE IN THE FUTURE. ### -# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 The SCons Foundation -# src/script/README.txt 4577 2009/12/27 19:44:43 scons +# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 The SCons Foundation +# src/script/README.txt 4629 2010/01/17 22:23:21 scons SCons - a software construction tool - Version 1.2.0.d20091224 + Version 1.2.0.d20100117 This is an alpha release of SCons, a tool for building software (and diff --git a/src/script/scons-post-install.py b/src/script/scons-post-install.py index 7c715d7..53ea180 100644 --- a/src/script/scons-post-install.py +++ b/src/script/scons-post-install.py @@ -9,7 +9,7 @@ # # SCons - a Software Constructor # -# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 The SCons Foundation +# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 The SCons Foundation # # Permission is hereby granted, free of charge, to any person obtaining # a copy of this software and associated documentation files (the @@ -31,7 +31,7 @@ # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. # -__revision__ = "src/script/scons-post-install.py 4577 2009/12/27 19:44:43 scons" +__revision__ = "src/script/scons-post-install.py 4629 2010/01/17 22:23:21 scons" import os.path import sys diff --git a/src/script/scons-time.py b/src/script/scons-time.py index dafbe4b..969cfa6 100644 --- a/src/script/scons-time.py +++ b/src/script/scons-time.py @@ -9,7 +9,7 @@ # # -# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 The SCons Foundation +# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 The SCons Foundation # # Permission is hereby granted, free of charge, to any person obtaining # a copy of this software and associated documentation files (the @@ -33,7 +33,7 @@ from __future__ import nested_scopes -__revision__ = "src/script/scons-time.py 4577 2009/12/27 19:44:43 scons" +__revision__ = "src/script/scons-time.py 4629 2010/01/17 22:23:21 scons" import getopt import glob diff --git a/src/script/scons.bat b/src/script/scons.bat index 566387a..69fa8f1 100644 --- a/src/script/scons.bat +++ b/src/script/scons.bat @@ -1,11 +1,11 @@ -@REM Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 The SCons Foundation
-@REM src/script/scons.bat 4577 2009/12/27 19:44:43 scons
+@REM Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 The SCons Foundation
+@REM src/script/scons.bat 4629 2010/01/17 22:23:21 scons
@echo off
set SCONS_ERRORLEVEL=
if "%OS%" == "Windows_NT" goto WinNT
@REM for 9x/Me you better not have more than 9 args
-python -c "from os.path import join; import sys; sys.path = [ join(sys.prefix, 'Lib', 'site-packages', 'scons-1.2.0.d20091224'), join(sys.prefix, 'Lib', 'site-packages', 'scons'), join(sys.prefix, 'scons-1.2.0.d20091224'), join(sys.prefix, 'scons')] + sys.path; import SCons.Script; SCons.Script.main()" %1 %2 %3 %4 %5 %6 %7 %8 %9
+python -c "from os.path import join; import sys; sys.path = [ join(sys.prefix, 'Lib', 'site-packages', 'scons-1.2.0.d20100117'), join(sys.prefix, 'Lib', 'site-packages', 'scons'), join(sys.prefix, 'scons-1.2.0.d20100117'), join(sys.prefix, 'scons')] + sys.path; import SCons.Script; SCons.Script.main()" %1 %2 %3 %4 %5 %6 %7 %8 %9
@REM no way to set exit status of this script for 9x/Me
goto endscons
@@ -17,7 +17,7 @@ goto endscons setlocal
@REM ensure the script will be executed with the Python it was installed for
set path=%~dp0;%~dp0..;%path%
-python -c "from os.path import join; import sys; sys.path = [ join(sys.prefix, 'Lib', 'site-packages', 'scons-1.2.0.d20091224'), join(sys.prefix, 'Lib', 'site-packages', 'scons'), join(sys.prefix, 'scons-1.2.0.d20091224'), join(sys.prefix, 'scons')] + sys.path; import SCons.Script; SCons.Script.main()" %*
+python -c "from os.path import join; import sys; sys.path = [ join(sys.prefix, 'Lib', 'site-packages', 'scons-1.2.0.d20100117'), join(sys.prefix, 'Lib', 'site-packages', 'scons'), join(sys.prefix, 'scons-1.2.0.d20100117'), join(sys.prefix, 'scons')] + sys.path; import SCons.Script; SCons.Script.main()" %*
endlocal & set SCONS_ERRORLEVEL=%ERRORLEVEL%
if NOT "%COMSPEC%" == "%SystemRoot%\system32\cmd.exe" goto returncode
diff --git a/src/script/scons.py b/src/script/scons.py index 6e21a09..219dd73 100644 --- a/src/script/scons.py +++ b/src/script/scons.py @@ -2,7 +2,7 @@ # # SCons - a Software Constructor # -# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 The SCons Foundation +# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 The SCons Foundation # # Permission is hereby granted, free of charge, to any person obtaining # a copy of this software and associated documentation files (the @@ -24,15 +24,15 @@ # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. # -__revision__ = "src/script/scons.py 4577 2009/12/27 19:44:43 scons" +__revision__ = "src/script/scons.py 4629 2010/01/17 22:23:21 scons" -__version__ = "1.2.0.d20091224" +__version__ = "1.2.0.d20100117" -__build__ = "r4577[MODIFIED]" +__build__ = "r4629" __buildsys__ = "scons-dev" -__date__ = "2009/12/27 19:44:43" +__date__ = "2010/01/17 22:23:21" __developer__ = "scons" diff --git a/src/script/sconsign.py b/src/script/sconsign.py index 406c7f5..dcaad40 100644 --- a/src/script/sconsign.py +++ b/src/script/sconsign.py @@ -2,7 +2,7 @@ # # SCons - a Software Constructor # -# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 The SCons Foundation +# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 The SCons Foundation # # Permission is hereby granted, free of charge, to any person obtaining # a copy of this software and associated documentation files (the @@ -24,15 +24,15 @@ # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. # -__revision__ = "src/script/sconsign.py 4577 2009/12/27 19:44:43 scons" +__revision__ = "src/script/sconsign.py 4629 2010/01/17 22:23:21 scons" -__version__ = "1.2.0.d20091224" +__version__ = "1.2.0.d20100117" -__build__ = "r4577[MODIFIED]" +__build__ = "r4629" __buildsys__ = "scons-dev" -__date__ = "2009/12/27 19:44:43" +__date__ = "2010/01/17 22:23:21" __developer__ = "scons" diff --git a/src/script/setup.py b/src/script/setup.py index 4f958f6..e204473 100644 --- a/src/script/setup.py +++ b/src/script/setup.py @@ -1,5 +1,5 @@ # -# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009 The SCons Foundation +# Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 The SCons Foundation # # Permission is hereby granted, free of charge, to any person obtaining # a copy of this software and associated documentation files (the @@ -21,7 +21,7 @@ # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. # -__revision__ = "src/script/setup.py 4577 2009/12/27 19:44:43 scons" +__revision__ = "src/script/setup.py 4629 2010/01/17 22:23:21 scons" import os import os.path @@ -36,7 +36,7 @@ if head: from distutils.core import setup setup(name = "scons-script", - version = "1.2.0.d20091224", + version = "1.2.0.d20100117", description = "an Open Source software construction tool script", long_description = """SCons is an Open Source software construction tool--that is, a build tool; an improved substitute for the classic Make utility; a better way to build |