summaryrefslogtreecommitdiff
path: root/src/setup.py
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-16 06:58:13 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-16 06:58:13 +0100
commite20c9557371eacec533588d33b4bebd543ba178f (patch)
treed48d297298e410a3068d647c95f2d06e635015b8 /src/setup.py
parentf681a1fb71c146c754f57508afac240d0e1b47e1 (diff)
Imported Upstream version 2.4.1upstream/2.4.1
Diffstat (limited to 'src/setup.py')
-rw-r--r--src/setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/setup.py b/src/setup.py
index d5bcc10..3b7a119 100644
--- a/src/setup.py
+++ b/src/setup.py
@@ -32,13 +32,13 @@ NOTE: Installed SCons is not importable like usual Python packages. It is
below is dedicated to make it happen on various platforms.
"""
-__revision__ = "src/setup.py rel_2.4.0:3365:9259ea1c13d7 2015/09/21 14:03:43 bdbaddog"
+__revision__ = "src/setup.py rel_2.4.1:3453:73fefd3ea0b0 2015/11/09 03:25:05 bdbaddog"
import os
import stat
import sys
-Version = "2.4.0"
+Version = "2.4.1"
man_pages = [
'scons.1',
@@ -343,7 +343,7 @@ class install_scripts(_install_scripts):
self.copy_scons(src, scons_version_bat)
# --- distutils copy/paste ---
- if os.name == 'posix':
+ if hasattr(os, 'chmod') and hasattr(os,'stat'):
# Set the executable bits (owner, group, and world) on
# all the scripts we just installed.
for file in self.get_outputs():