summaryrefslogtreecommitdiff
path: root/doc/user
diff options
context:
space:
mode:
Diffstat (limited to 'doc/user')
-rw-r--r--doc/user/build-install.xml16
-rw-r--r--doc/user/factories.xml18
-rw-r--r--doc/user/misc.xml9
-rw-r--r--doc/user/sconf.xml20
4 files changed, 50 insertions, 13 deletions
diff --git a/doc/user/build-install.xml b/doc/user/build-install.xml
index f5e4da4..d4f3819 100644
--- a/doc/user/build-install.xml
+++ b/doc/user/build-install.xml
@@ -6,7 +6,7 @@
<!ENTITY % scons SYSTEM "../scons.mod">
%scons;
-
+
<!ENTITY % builders-mod SYSTEM "../generated/builders.mod">
%builders-mod;
<!ENTITY % functions-mod SYSTEM "../generated/functions.mod">
@@ -15,7 +15,7 @@
%tools-mod;
<!ENTITY % variables-mod SYSTEM "../generated/variables.mod">
%variables-mod;
-
+
]>
<chapter id="chap-build-install"
@@ -79,7 +79,7 @@
to configure simple &SCons; builds without knowing Python,
so you can skip this section if you
want to dive in and pick up things
- by example- -or, of course, if you are
+ by example- -or, of course, if you are
already familiar with Python.
</para>
@@ -147,7 +147,7 @@ Python 2.5.1
<para>
- &SCons; will work with any 2.x version of Python from 2.4 on;
+ &SCons; will work with any 2.x version of Python from 2.7 on;
3.0 and later are not yet supported.
If you need to install Python and have a choice,
we recommend using the most recent 2.x Python version available.
@@ -209,7 +209,7 @@ Python 2.5.1
a specific &SCons; RPM file,
you can download and install from the
generic RPM provided by the &SCons; project.
- This will install the
+ This will install the
SCons script(s) in <filename>/usr/bin</filename>,
and the SCons library modules in
<filename>/usr/lib/scons</filename>.
@@ -530,7 +530,7 @@ Python 2.5.1
This would
install the <application>scons</application> script in
<filename>/opt/scons/bin</filename>
- and the build engine in
+ and the build engine in
<filename>/opt/scons/lib/scons</filename>,
</para>
@@ -566,7 +566,7 @@ Python 2.5.1
relative to the user's <literal>$HOME</literal> directory,
the &scons; script in
<filename>$HOME/bin</filename>
- and the build engine in
+ and the build engine in
<filename>$HOME/lib/scons</filename>,
simply type:
@@ -719,7 +719,7 @@ $ <userinput>python setup.py install --prefix=$HOME</userinput>
while: statements look like
break statements look like
-
+
continue statements look like
</para>
diff --git a/doc/user/factories.xml b/doc/user/factories.xml
index e620ece..7fe0efd 100644
--- a/doc/user/factories.xml
+++ b/doc/user/factories.xml
@@ -176,6 +176,24 @@ touch $*
<scons_output_command>scons -Q</scons_output_command>
</scons_output>
+ <para>
+ The &Copy; factory has a third optional argument which controls
+ how symlinks are copied.
+ </para>
+
+ <para>
+ </para>
+
+ <scons_example name="factories_SymlinkCopy">
+ <file name ="SymlinkCopy" printme="1">
+# Symbolic link shallow copied as a new symbolic link:
+Command("LinkIn", "LinkOut", Copy("$TARGET", "$SOURCE"[, True]))
+
+# Symbolic link target copied as a file or directory:
+Command("LinkIn", "FileOrDirectoryOut", Copy("$TARGET", "$SOURCE", False))
+ </file>
+ </scons_example>
+
</section>
<section>
diff --git a/doc/user/misc.xml b/doc/user/misc.xml
index 0c56b43..2410714 100644
--- a/doc/user/misc.xml
+++ b/doc/user/misc.xml
@@ -2,7 +2,7 @@
<!DOCTYPE sconsdoc [
<!ENTITY % scons SYSTEM "../scons.mod">
%scons;
-
+
<!ENTITY % builders-mod SYSTEM "../generated/builders.mod">
%builders-mod;
<!ENTITY % functions-mod SYSTEM "../generated/functions.mod">
@@ -56,11 +56,10 @@
<para>
- Although the &SCons; code itself will run
- on any 2.x Python version 2.4 or later,
+ Although the &SCons; code itself will run
+ on any 2.x Python version 2.7 or later,
you are perfectly free to make use of
- Python syntax and modules from more modern versions
- (for example, Python 2.5 or 2.6)
+ Python syntax and modules from later versions
when writing your &SConscript; files
or your own local modules.
If you do this, it's usually helpful to
diff --git a/doc/user/sconf.xml b/doc/user/sconf.xml
index 410325c..d84cc67 100644
--- a/doc/user/sconf.xml
+++ b/doc/user/sconf.xml
@@ -282,6 +282,26 @@ env = conf.Finish()
</sconstruct>
</section>
+ <section>
+ <title>Checking the size of a datatype</title>
+ <para>
+ Check the size of a datatype by using the &CheckTypeSize; method:
+ </para>
+
+ <sconstruct>
+env = Environment()
+conf = Configure(env)
+int_size = conf.CheckTypeSize('unsigned int')
+print 'sizeof unsigned int is', int_size
+env = conf.Finish()
+ </sconstruct>
+
+ <screen>
+% <userinput>scons -Q</userinput>
+sizeof unsigned int is 4
+scons: `.' is up to date.
+ </screen>
+ </section>
<section>
<title>Adding Your Own Custom Checks</title>