summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-01-31 20:46:01 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-01-31 20:46:01 +0100
commitad361a847eeb6d023dba25c2a618ee9fc2f95774 (patch)
tree757a1ec4a78e09e7552a3b91249ddfbac5eb2a9b
parent55e3dbe64053c4231399a8cf83999a4a8753358b (diff)
Create Bibtex bibliography always
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0120-fix-bibtex-call.patch40
-rw-r--r--debian/patches/series1
3 files changed, 48 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 640cc62..242347c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+scons (2.4.1-2) UNRELEASED; urgency=medium
+
+ * New debian/patches/0120-fix-bibtex-call.patch to create
+ Bibtex bibliography always (Closes: #749716).
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 31 Jan 2016 20:40:03 +0100
+
scons (2.4.1-1) unstable; urgency=medium
* New upstream version.
diff --git a/debian/patches/0120-fix-bibtex-call.patch b/debian/patches/0120-fix-bibtex-call.patch
new file mode 100644
index 0000000..ea82ca5
--- /dev/null
+++ b/debian/patches/0120-fix-bibtex-call.patch
@@ -0,0 +1,40 @@
+Description: Create Bibtex bibliography always
+Author: Alvaro G. M. <alvaro.gamez@hazent.com>
+Bug: http://scons.tigris.org/issues/show_bug.cgi?id=2967
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=749716
+Forwarded: http://scons.tigris.org/issues/show_bug.cgi?id=2967
+Last-Update: 2016-01-31
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/engine/SCons/Tool/tex.py
+===================================================================
+--- trunk.orig/engine/SCons/Tool/tex.py
++++ trunk/engine/SCons/Tool/tex.py
+@@ -346,6 +346,13 @@ def InternalLaTeXAuxAction(XXXLaTeXActio
+ if result != 0:
+ check_file_error_message(env['BIBTEX'], 'blg')
+ must_rerun_latex = True
++ if Verbose:
++ print "Need to run bibtex on ",auxfilename
++ bibfile = env.fs.File(SCons.Util.splitext(target_aux)[0])
++ result = BibTeXAction(bibfile, bibfile, env)
++ if result != 0:
++ check_file_error_message(env['BIBTEX'], 'blg')
++ must_rerun_latex = True
+
+ # Now decide if biber will need to be run.
+ # When the backend for biblatex is biber (by choice or default) the
+@@ -369,6 +376,13 @@ def InternalLaTeXAuxAction(XXXLaTeXActio
+ if result != 0:
+ check_file_error_message(env['BIBER'], 'blg')
+ must_rerun_latex = True
++ if Verbose:
++ print "Need to run biber on ",bcffilename
++ bibfile = env.fs.File(SCons.Util.splitext(target_bcf)[0])
++ result = BiberAction(bibfile, bibfile, env)
++ if result != 0:
++ check_file_error_message(env['BIBER'], 'blg')
++ must_rerun_latex = True
+
+ # Now decide if latex will need to be run again due to index.
+ if check_MD5(suffix_nodes['.idx'],'.idx') or (count == 1 and run_makeindex):
diff --git a/debian/patches/series b/debian/patches/series
index 7c9d075..3b82bac 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@
0105-java_ignore_nonexistent_files.patch
0110-remove_stale_files.patch
0100-parallel_build.patch
+0120-fix-bibtex-call.patch