summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-04-10 17:20:17 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-04-10 17:20:17 +0200
commitf02ffbae6d025e2ecedee7c0eb142c55b420b014 (patch)
tree966d9e09937d8f1d86e9093dfa9886e106359898
parent2b4e62c8dacc53317d63d987c4a8826a38bbf9aa (diff)
refresh patches
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/0110-remove_stale_files.patch2
-rw-r--r--debian/patches/0600-manpage-spelling.patch92
3 files changed, 95 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index a5a9882..4b702f1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
-scons (2.4.1-2) UNRELEASED; urgency=medium
+scons (2.5.0-1) UNRELEASED; urgency=medium
+ * New upstream release.
+ * Refresh patches.
* New debian/patches/0120-fix-bibtex-call.patch to create
Bibtex bibliography always (Closes: #749716).
* debian/watch:
diff --git a/debian/patches/0110-remove_stale_files.patch b/debian/patches/0110-remove_stale_files.patch
index 2c1273c..d4be6bf 100644
--- a/debian/patches/0110-remove_stale_files.patch
+++ b/debian/patches/0110-remove_stale_files.patch
@@ -7,7 +7,7 @@ Index: trunk/engine/SCons/Script/Main.py
===================================================================
--- trunk.orig/engine/SCons/Script/Main.py
+++ trunk/engine/SCons/Script/Main.py
-@@ -1105,6 +1105,21 @@ def _main(parser):
+@@ -1094,6 +1094,21 @@ def _main(parser):
print 'Found nothing to build'
exit_status = 2
diff --git a/debian/patches/0600-manpage-spelling.patch b/debian/patches/0600-manpage-spelling.patch
index 13936c6..6b3b555 100644
--- a/debian/patches/0600-manpage-spelling.patch
+++ b/debian/patches/0600-manpage-spelling.patch
@@ -8,7 +8,16 @@ Index: trunk/scons.1
===================================================================
--- trunk.orig/scons.1
+++ trunk/scons.1
-@@ -6576,7 +6576,7 @@ file\&. Note, that the updated
+@@ -443,7 +443,7 @@ call should use or generate the results
+ .PP
+ \-\-config=auto
+ .RS 4
+-scons will use its normal dependency mechanisms to decide if a test must be rebuilt or not\&. This saves time by not running the same configuration tests every time you invoke scons, but will overlook changes in system header files or external commands (such as compilers) if you don\*(Aqt specify those dependecies explicitly\&. This is the default behavior\&.
++scons will use its normal dependency mechanisms to decide if a test must be rebuilt or not\&. This saves time by not running the same configuration tests every time you invoke scons, but will overlook changes in system header files or external commands (such as compilers) if you don\*(Aqt specify those dependencies explicitly\&. This is the default behavior\&.
+ .RE
+ .PP
+ \-\-config=force
+@@ -6582,7 +6582,7 @@ file\&. Note, that the updated
POT
and
PO
@@ -17,3 +26,84 @@ Index: trunk/scons.1
po/
directory contains
LINGUAS
+@@ -7122,7 +7122,7 @@ Example:
+ AllowSubstExceptions()
+
+ # Also allow a string containing a zero\-division expansion
+-# like \*(Aq${1 / 0}\*(Aq to evalute to \*(Aq\*(Aq\&.
++# like \*(Aq${1 / 0}\*(Aq to evaluate to \*(Aq\*(Aq\&.
+ AllowSubstExceptions(IndexError, NameError, ZeroDivisionError)
+ .fi
+ .if n \{\
+@@ -9198,7 +9198,7 @@ Return([vars\&.\&.\&., stop=])
+ .RS 4
+ By default, this stops processing the current SConscript file and returns to the calling SConscript file the values of the variables named in the
+ \fIvars\fR
+-string arguments\&. Multiple strings contaning variable names may be passed to
++string arguments\&. Multiple strings containing variable names may be passed to
+ \fBReturn\fR\&. Any strings that contain white space
+ .sp
+ The optional
+@@ -11373,7 +11373,7 @@ is used to create PDF output from an XML
+ .PP
+ DOCBOOK_FOPFLAGS
+ .RS 4
+-Additonal command\-line flags for the PDF renderer
++Additional command\-line flags for the PDF renderer
+ fop
+ or
+ xep\&.
+@@ -11400,7 +11400,7 @@ is used to resolve XIncludes for a given
+ .PP
+ DOCBOOK_XMLLINTFLAGS
+ .RS 4
+-Additonal command\-line flags for the external executable
++Additional command\-line flags for the external executable
+ xmllint\&.
+ .RE
+ .PP
+@@ -11431,7 +11431,7 @@ is used to transform an XML file via a g
+ .PP
+ DOCBOOK_XSLTPROCFLAGS
+ .RS 4
+-Additonal command\-line flags for the external executable
++Additional command\-line flags for the external executable
+ xsltproc
+ (or
+ saxon,
+@@ -11440,7 +11440,7 @@ xalan)\&.
+ .PP
+ DOCBOOK_XSLTPROCPARAMS
+ .RS 4
+-Additonal parameters that are not intended for the XSLT processor executable, but the XSL processing itself\&. By default, they get appended at the end of the command line for
++Additional parameters that are not intended for the XSLT processor executable, but the XSL processing itself\&. By default, they get appended at the end of the command line for
+ saxon
+ and
+ saxon\-xslt, respectively\&.
+@@ -14052,7 +14052,7 @@ A list of installed versions of the Metr
+ .PP
+ NAME
+ .RS 4
+-Specfies the name of the project to package\&.
++Specifies the name of the project to package\&.
+ .RE
+ .PP
+ no_import_lib
+@@ -16437,7 +16437,7 @@ builder\&.
+ .PP
+ _XGETTEXTFROMFLAGS
+ .RS 4
+-Internal "macro"\&. Genrates list of
++Internal "macro"\&. Generates list of
+ \-D<dir>
+ flags from the
+ \fB$XGETTEXTPATH\fR
+@@ -18375,7 +18375,7 @@ a = Action("build < ${SOURCE\&.file} > $
+ The
+ \fBAction\fR() global function also takes an
+ \fBexitstatfunc\fR
+-keyword argument which specifies a function that is passed the exit status (or return value) from the specified action and can return an arbitrary or modified value\&. This can be used, for example, to specify that an Action object\*(Aqs return value should be ignored under special conditions and SCons should, therefore, consider that the action always suceeds:
++keyword argument which specifies a function that is passed the exit status (or return value) from the specified action and can return an arbitrary or modified value\&. This can be used, for example, to specify that an Action object\*(Aqs return value should be ignored under special conditions and SCons should, therefore, consider that the action always succeeds:
+ .sp
+ .if n \{\
+ .RS 4