summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ehrhardt <christian.ehrhardt@canonical.com>2018-11-08 08:10:12 +0100
committerChristian Ehrhardt <christian.ehrhardt@canonical.com>2018-11-08 08:11:58 +0100
commit074c5e3f96026aaa37153dc7b7a17c64be473fba (patch)
tree94c0e535707041d628a517352c7f69fe9da99372
parente3984312068f8e535ca5066f37a72317ddaf1b61 (diff)
d/p/0110-remove_stale_files.patch: update for py3 compatibility (Closes: #893740)
Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/0110-remove_stale_files.patch2
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ae678cf..3c2a005 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,15 @@
scons (3.0.1-2) UNRELEASED; urgency=medium
+ [ Ondřej Nový ]
* d/control: Remove ancient X-Python-Version field
* d/copyright: Use https protocol in Format field
* d/control: Set Vcs-* to salsa.debian.org
* d/watch: Use https protocol
+ [ Christian Ehrhardt ]
+ * d/p/0110-remove_stale_files.patch: update for python3
+ compatibility (Closes: #893740)
+
-- Ondřej Nový <onovy@debian.org> Mon, 01 Oct 2018 09:49:30 +0200
scons (3.0.1-1) unstable; urgency=medium
diff --git a/debian/patches/0110-remove_stale_files.patch b/debian/patches/0110-remove_stale_files.patch
index b3a94d2..298d47c 100644
--- a/debian/patches/0110-remove_stale_files.patch
+++ b/debian/patches/0110-remove_stale_files.patch
@@ -13,7 +13,7 @@ Index: trunk/engine/SCons/Script/Main.py
+ # Remove temporary files left by SCons
+ if options.clean:
-+ if os.environ.has_key('DH_INTERNAL_OPTIONS'):
++ if 'DH_INTERNAL_OPTIONS' in os.environ:
+ import shutil
+ for path in ('.sconsign.dblite', '.sconf_temp'):
+ try: