summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-10-12 21:18:07 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-10-12 21:18:07 +0200
commit279d864b80870c0e7cb3e0a3dc37e338d15f4be8 (patch)
treef08bde597e0a949a7ad941276ec31f110b48831d
parent659f5379b685d75a6de6bc42e8f70bf9ff695342 (diff)
d/rules, d/control: add python3 support
-rw-r--r--debian/changelog2
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules2
3 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index a09076f..9d6e38c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,8 +9,10 @@ scons (3.0.1-2) UNRELEASED; urgency=medium
* Declare compliance with Debian Policy 4.2.1 (No changes needed).
* debian/control:
- Remove trailing whitespaces.
+ - Add python3 support.
* debian/rules:
- Remove trailing whitespaces.
+ - Add python3 support.
-- Jörg Frings-Fürst <debian@jff.email> Fri, 12 Oct 2018 19:47:43 +0200
diff --git a/debian/control b/debian/control
index 6c5d7ba..10eced4 100644
--- a/debian/control
+++ b/debian/control
@@ -6,9 +6,9 @@ Uploaders: Laszlo Boszormenyi (GCS) <gcs@debian.org>
Build-Depends:
debhelper (>= 11),
dh-python,
- python (>= 2.7~)
+ python-all,
+ python3-all
Standards-Version: 4.2.1
-X-Python-Version: >= 2.7
Homepage: http://www.scons.org/
Vcs-Git: https://anonscm.debian.org/cgit/collab-maint/scons.git
Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/scons.git
diff --git a/debian/rules b/debian/rules
index 3df1e98..9f5141f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
%:
- dh $@ --with python2
+ dh $@ --with python2, python3
clean:
rm -fr build