diff options
author | Luca Falavigna <dktrkranz@debian.org> | 2010-06-15 09:21:32 +0000 |
---|---|---|
committer | Luca Falavigna <dktrkranz@debian.org> | 2010-06-15 09:21:32 +0000 |
commit | 07fc59e19636a4fc97a18b2038f3fe1c72a94000 (patch) | |
tree | 79d4a6239d81b2ccb4752d4f5ca25e0a7d3b4d4b /setup.py | |
parent | 7f642861f3946d4241cbd668de258293ba92767a (diff) | |
parent | 340d57481935334465037d97c0db1555b70c0eb1 (diff) |
Merge commit 'upstream/2.0.0'
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 18 |
1 files changed, 8 insertions, 10 deletions
@@ -19,17 +19,15 @@ # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. -# -__revision__ = "src/setup.py 4720 2010/03/24 03:14:11 jars" +__revision__ = "src/setup.py 5023 2010/06/14 22:05:46 scons" import os import os.path import stat -import string import sys -Version = "1.3.0" +Version = "2.0.0.final.0" man_pages = [ 'scons.1', @@ -77,7 +75,7 @@ _install_lib = distutils.command.install_lib.install_lib _install_scripts = distutils.command.install_scripts.install_scripts _build_scripts = distutils.command.build_scripts.build_scripts -class _options: +class _options(object): pass Options = _options() @@ -198,7 +196,7 @@ def get_scons_prefix(libdir, is_win32): if head == os.sep: break head, tail = os.path.split(head) - if string.lower(tail)[:6] == "python": + if tail.lower()[:6] == "python": # Found the Python library directory... if is_win32: # ...on Win32 systems, "scons" goes in the directory: @@ -297,8 +295,8 @@ class install_scripts(_install_scripts): create_version_script = self.do_nothing inputs = self.get_inputs() - bat_scripts = filter(lambda x: x[-4:] == '.bat', inputs) - non_bat_scripts = filter(lambda x: x[-4:] != '.bat', inputs) + bat_scripts = [x for x in inputs if x[-4:] == '.bat'] + non_bat_scripts = [x for x in inputs if x[-4:] != '.bat'] self.outfiles = [] self.mkpath(self.install_dir) @@ -415,10 +413,10 @@ arguments = { 'build_scripts' : build_scripts} } -apply(distutils.core.setup, (), arguments) +distutils.core.setup(**arguments) if Installed: - print string.join(Installed, '\n') + print '\n'.join(Installed) # Local Variables: # tab-width:4 |