diff options
author | Jörg Frings-Fürst <debian@jff-webhosting.net> | 2015-06-21 07:06:07 +0200 |
---|---|---|
committer | Jörg Frings-Fürst <debian@jff-webhosting.net> | 2015-06-21 07:06:07 +0200 |
commit | b0f56d74df2a6904ddceb963833d4ea357251853 (patch) | |
tree | cad0dca521f39475abf774e513b7883ee96ea13d /setup.py | |
parent | 665e78e013bc207a5ec35e4bc41daf2e464f6ed3 (diff) |
Imported Upstream version 2.3.5upstream/2.3.5
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 16 |
1 files changed, 13 insertions, 3 deletions
@@ -1,5 +1,5 @@ # -# Copyright (c) 2001 - 2014 The SCons Foundation +# Copyright (c) 2001 - 2015 The SCons Foundation # # Permission is hereby granted, free of charge, to any person obtaining # a copy of this software and associated documentation files (the @@ -32,13 +32,13 @@ NOTE: Installed SCons is not importable like usual Python packages. It is below is dedicated to make it happen on various platforms. """ -__revision__ = "src/setup.py 2014/09/27 12:51:43 garyo" +__revision__ = "src/setup.py pchdll:3325:cd517fae59a4 2015/06/18 06:53:27 bdbaddog" import os import stat import sys -Version = "2.3.4" +Version = "2.3.5" man_pages = [ 'scons.1', @@ -81,6 +81,16 @@ import distutils.command.install_data import distutils.command.install_lib import distutils.command.install_scripts import distutils.command.build_scripts +import distutils.msvccompiler + +def get_build_version(): + """ monkey patch distutils msvc version if we're not on windows. + We need to use vc version 9 for python 2.7.x and it defaults to 6 + for non-windows platforms and there is no way to override it besides + monkey patching""" + return 9 + +distutils.msvccompiler.get_build_version = get_build_version _install = distutils.command.install.install _install_data = distutils.command.install_data.install_data |