summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-16 05:58:13 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-16 05:58:13 +0100
commit6a570afd28bccdb118edde36488ba9834494d6c7 (patch)
tree162100eb912a704d570559c85484ae6d6943fc76 /setup.py
parent72c39ad485d174c2e8e1fef34b8e9e392a94458a (diff)
Imported Upstream version 2.4.1upstream/2.4.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index d5bcc10..3b7a119 100644
--- a/setup.py
+++ b/setup.py
@@ -32,13 +32,13 @@ NOTE: Installed SCons is not importable like usual Python packages. It is
below is dedicated to make it happen on various platforms.
"""
-__revision__ = "src/setup.py rel_2.4.0:3365:9259ea1c13d7 2015/09/21 14:03:43 bdbaddog"
+__revision__ = "src/setup.py rel_2.4.1:3453:73fefd3ea0b0 2015/11/09 03:25:05 bdbaddog"
import os
import stat
import sys
-Version = "2.4.0"
+Version = "2.4.1"
man_pages = [
'scons.1',
@@ -343,7 +343,7 @@ class install_scripts(_install_scripts):
self.copy_scons(src, scons_version_bat)
# --- distutils copy/paste ---
- if os.name == 'posix':
+ if hasattr(os, 'chmod') and hasattr(os,'stat'):
# Set the executable bits (owner, group, and world) on
# all the scripts we just installed.
for file in self.get_outputs():