summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README.source18
-rw-r--r--debian/changelog15
-rw-r--r--debian/control3
-rw-r--r--debian/copyright6
-rw-r--r--debian/files1
-rw-r--r--debian/patches/0110-remove_stale_files.patch8
-rw-r--r--debian/patches/0115-secure_script_scons.patch2
-rw-r--r--debian/patches/0120-fix-bibtex-call.patch8
-rw-r--r--debian/patches/0600-manpage-spelling.patch33
9 files changed, 69 insertions, 25 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..e4f2b3d
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,18 @@
+Hello,
+
+now I use the branching model from Vincent Driessen[1].
+
+I use the gitflow-avh[2]. with the Documentation[3].
+The Debian package can be found here[4].
+
+Please upload unattended uploads use a branch feature/<your title>.
+
+
+Many thanks.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Fri, 02 Jun 2017 19:00:40 +0200
+
+[1] http://nvie.com/posts/a-successful-git-branching-model/
+[2] https://github.com/petervanderdoes/gitflow-avh
+[3] https://github.com/petervanderdoes/gitflow-avh/wiki
+[4] https://tracker.debian.org/pkg/git-flow
diff --git a/debian/changelog b/debian/changelog
index ca830c5..8db961b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+scons (3.0.0-1) unstable; urgency=medium
+
+ * New upstream release.
+ - Refresh patches.
+ + patches/0110-remove_stale_files.patch
+ + patches/0115-secure_script_scons.patch
+ + patches/0120-fix-bibtex-call.patch
+ + patches/0600-manpage-spelling.patch
+ * New README.source to explain the branching model used.
+ * Declare compliance with Debian Policy 4.1.0. (No changes needed).
+ * debian/copyright:
+ - Add year 2017 to *, debian and debian/patches.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 01 Oct 2017 13:30:32 +0200
+
scons (2.5.1-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index fca11e7..ce9b1b2 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Build-Depends:
debhelper (>= 10),
dh-python,
python (>= 2.7~)
-Standards-Version: 3.9.8
+Standards-Version: 4.1.0
X-Python-Version: >= 2.7
Homepage: http://www.scons.org/
Vcs-Git: https://anonscm.debian.org/cgit/collab-maint/scons.git
@@ -22,3 +22,4 @@ Description: replacement for make
support. SCons rule sets are Python scripts so as well as the features
it provides itself SCons allows you to use the full power of Python
to control compilation.
+
diff --git a/debian/copyright b/debian/copyright
index 12c6fd4..b5a45f4 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -4,7 +4,7 @@ Upstream-Contact: Steven Knight <knight@baldmt.com>
Source: http://www.scons.org
Files: *
-Copyright: 2001-2016 The SCons Foundation
+Copyright: 2001-2017 The SCons Foundation
1999-2006 Gregory P. Ward
2001-2003 Steven Knight
2001-2004 Twisted Matrix Laboratories
@@ -17,12 +17,12 @@ Files: debian/*
Copyright: 2002 Moshe Zadka <moshez@debian.org>
2003-2008 Mark Brown <broonie@debian.org>
2008-2014 Luca Falavigna <dktrkranz@ubuntu.com>
- 2014-2016 Jörg Frings-Fürst <debian@jff-webhosting.net>
+ 2014-2017 Jörg Frings-Fürst <debian@jff-webhosting.net>
License: GPL-3.0+
Files: debian/patches/*
Copyright: 2010-2014 Luca Falavigna <dktrkranz@ubuntu.com>
- 2014-2016 Jörg Frings-Fürst <debian@jff-webhosting.net>
+ 2014-2017 Jörg Frings-Fürst <debian@jff-webhosting.net>
License: Expat
License: Expat
diff --git a/debian/files b/debian/files
new file mode 100644
index 0000000..55c5400
--- /dev/null
+++ b/debian/files
@@ -0,0 +1 @@
+scons_3.0.0-1_source.buildinfo devel optional
diff --git a/debian/patches/0110-remove_stale_files.patch b/debian/patches/0110-remove_stale_files.patch
index d4be6bf..b3a94d2 100644
--- a/debian/patches/0110-remove_stale_files.patch
+++ b/debian/patches/0110-remove_stale_files.patch
@@ -7,8 +7,8 @@ Index: trunk/engine/SCons/Script/Main.py
===================================================================
--- trunk.orig/engine/SCons/Script/Main.py
+++ trunk/engine/SCons/Script/Main.py
-@@ -1094,6 +1094,21 @@ def _main(parser):
- print 'Found nothing to build'
+@@ -1106,6 +1106,21 @@ def _main(parser):
+ print('Found nothing to build')
exit_status = 2
+ # Remove temporary files left by SCons
@@ -18,10 +18,10 @@ Index: trunk/engine/SCons/Script/Main.py
+ for path in ('.sconsign.dblite', '.sconf_temp'):
+ try:
+ if os.path.isfile(path):
-+ print 'Removing autogenerated file %s' % path
++ print ('Removing autogenerated file %s' % (path))
+ os.remove(path)
+ if os.path.isdir(path):
-+ print 'Removing autogenerated directory %s' % path
++ print ('Removing autogenerated directory %s' % (path))
+ shutil.rmtree(path)
+ except OSError:
+ pass
diff --git a/debian/patches/0115-secure_script_scons.patch b/debian/patches/0115-secure_script_scons.patch
index 7463f32..24d9cf6 100644
--- a/debian/patches/0115-secure_script_scons.patch
+++ b/debian/patches/0115-secure_script_scons.patch
@@ -8,7 +8,7 @@ Index: trunk/script/scons
===================================================================
--- trunk.orig/script/scons
+++ trunk/script/scons
-@@ -75,8 +75,8 @@ if "SCONS_LIB_DIR" in os.environ:
+@@ -77,8 +77,8 @@ if "SCONS_LIB_DIR" in os.environ:
# - running from source takes priority (since 2.3.2), excluding SCONS_LIB_DIR settings
script_path = os.path.abspath(os.path.dirname(__file__))
diff --git a/debian/patches/0120-fix-bibtex-call.patch b/debian/patches/0120-fix-bibtex-call.patch
index ea82ca5..0bdbee8 100644
--- a/debian/patches/0120-fix-bibtex-call.patch
+++ b/debian/patches/0120-fix-bibtex-call.patch
@@ -10,12 +10,12 @@ Index: trunk/engine/SCons/Tool/tex.py
===================================================================
--- trunk.orig/engine/SCons/Tool/tex.py
+++ trunk/engine/SCons/Tool/tex.py
-@@ -346,6 +346,13 @@ def InternalLaTeXAuxAction(XXXLaTeXActio
+@@ -347,6 +347,13 @@ def InternalLaTeXAuxAction(XXXLaTeXActio
if result != 0:
check_file_error_message(env['BIBTEX'], 'blg')
must_rerun_latex = True
+ if Verbose:
-+ print "Need to run bibtex on ",auxfilename
++ print ("Need to run bibtex on " + auxfilename)
+ bibfile = env.fs.File(SCons.Util.splitext(target_aux)[0])
+ result = BibTeXAction(bibfile, bibfile, env)
+ if result != 0:
@@ -24,12 +24,12 @@ Index: trunk/engine/SCons/Tool/tex.py
# Now decide if biber will need to be run.
# When the backend for biblatex is biber (by choice or default) the
-@@ -369,6 +376,13 @@ def InternalLaTeXAuxAction(XXXLaTeXActio
+@@ -370,6 +377,13 @@ def InternalLaTeXAuxAction(XXXLaTeXActio
if result != 0:
check_file_error_message(env['BIBER'], 'blg')
must_rerun_latex = True
+ if Verbose:
-+ print "Need to run biber on ",bcffilename
++ print ("Need to run biber on " + bcffilename)
+ bibfile = env.fs.File(SCons.Util.splitext(target_bcf)[0])
+ result = BiberAction(bibfile, bibfile, env)
+ if result != 0:
diff --git a/debian/patches/0600-manpage-spelling.patch b/debian/patches/0600-manpage-spelling.patch
index f66ea23..4afc829 100644
--- a/debian/patches/0600-manpage-spelling.patch
+++ b/debian/patches/0600-manpage-spelling.patch
@@ -16,7 +16,16 @@ Index: trunk/scons.1
.RE
.PP
\-\-config=force
-@@ -6350,7 +6350,7 @@ env\&.Substfile(\*(Aqfoo\&.in\*(Aq, SUBS
+@@ -1472,7 +1472,7 @@ The tool definition (i\&.e\&. my_tool())
+ .PP
+ If no tool list is specified, then SCons will auto\-detect the installed tools using the PATH variable in the ENV construction variable and the platform name when the Environment is constructed\&. Changing the PATH variable after the Environment is constructed will not cause the tools to be redetected\&.
+ .PP
+-One feature now present within Scons is the ability to have nested tools\&. Tools which can be located within a subdirectory in the toolpath\&. With a nested tool name the dot represents a directory seperator
++One feature now present within Scons is the ability to have nested tools\&. Tools which can be located within a subdirectory in the toolpath\&. With a nested tool name the dot represents a directory separator
+ .sp
+ .if n \{\
+ .RS 4
+@@ -6376,7 +6376,7 @@ env\&.Substfile(\*(Aqfoo\&.in\*(Aq, SUBS
good_foo = [(\*(Aq$foobar\*(Aq, \*(Aq$foobar\*(Aq), (\*(Aq$foo\*(Aq, \*(Aq$foo\*(Aq)]
env\&.Substfile(\*(Aqfoo\&.in\*(Aq, SUBST_DICT = good_foo)
@@ -25,7 +34,7 @@ Index: trunk/scons.1
bad_bar = {\*(Aq@bar@\*(Aq: \*(Aq@soap@\*(Aq, \*(Aq@soap@\*(Aq: \*(Aqlye\*(Aq}
env\&.Substfile(\*(Aqbar\&.in\*(Aq, SUBST_DICT = bad_bar)
-@@ -6582,7 +6582,7 @@ file\&. Note, that the updated
+@@ -6608,7 +6608,7 @@ file\&. Note, that the updated
POT
and
PO
@@ -34,7 +43,7 @@ Index: trunk/scons.1
po/
directory contains
LINGUAS
-@@ -7122,7 +7122,7 @@ Example:
+@@ -7148,7 +7148,7 @@ Example:
AllowSubstExceptions()
# Also allow a string containing a zero\-division expansion
@@ -43,7 +52,7 @@ Index: trunk/scons.1
AllowSubstExceptions(IndexError, NameError, ZeroDivisionError)
.fi
.if n \{\
-@@ -9198,7 +9198,7 @@ Return([vars\&.\&.\&., stop=])
+@@ -9123,7 +9123,7 @@ Return([vars\&.\&.\&., stop=])
.RS 4
By default, this stops processing the current SConscript file and returns to the calling SConscript file the values of the variables named in the
\fIvars\fR
@@ -52,7 +61,7 @@ Index: trunk/scons.1
\fBReturn\fR\&. Any strings that contain white space
.sp
The optional
-@@ -10118,7 +10118,7 @@ function to create a copy of your source
+@@ -10023,7 +10023,7 @@ function to create a copy of your source
\fIvariant_dir\fR
is not found but exists under
\fIsrc_dir\fR, the file or directory is copied to
@@ -61,7 +70,7 @@ Index: trunk/scons.1
.sp
\fBVariantDir\fR
-@@ -11373,7 +11373,7 @@ is used to create PDF output from an XML
+@@ -11290,7 +11290,7 @@ is used to create PDF output from an XML
.PP
DOCBOOK_FOPFLAGS
.RS 4
@@ -70,7 +79,7 @@ Index: trunk/scons.1
fop
or
xep\&.
-@@ -11400,7 +11400,7 @@ is used to resolve XIncludes for a given
+@@ -11317,7 +11317,7 @@ is used to resolve XIncludes for a given
.PP
DOCBOOK_XMLLINTFLAGS
.RS 4
@@ -79,7 +88,7 @@ Index: trunk/scons.1
xmllint\&.
.RE
.PP
-@@ -11431,7 +11431,7 @@ is used to transform an XML file via a g
+@@ -11348,7 +11348,7 @@ is used to transform an XML file via a g
.PP
DOCBOOK_XSLTPROCFLAGS
.RS 4
@@ -88,7 +97,7 @@ Index: trunk/scons.1
xsltproc
(or
saxon,
-@@ -11440,7 +11440,7 @@ xalan)\&.
+@@ -11357,7 +11357,7 @@ xalan)\&.
.PP
DOCBOOK_XSLTPROCPARAMS
.RS 4
@@ -97,7 +106,7 @@ Index: trunk/scons.1
saxon
and
saxon\-xslt, respectively\&.
-@@ -14052,7 +14052,7 @@ A list of installed versions of the Metr
+@@ -14008,7 +14008,7 @@ A list of installed versions of the Metr
.PP
NAME
.RS 4
@@ -106,7 +115,7 @@ Index: trunk/scons.1
.RE
.PP
no_import_lib
-@@ -16437,7 +16437,7 @@ builder\&.
+@@ -16341,7 +16341,7 @@ builder\&.
.PP
_XGETTEXTFROMFLAGS
.RS 4
@@ -115,7 +124,7 @@ Index: trunk/scons.1
\-D<dir>
flags from the
\fB$XGETTEXTPATH\fR
-@@ -18375,7 +18375,7 @@ a = Action("build < ${SOURCE\&.file} > $
+@@ -18279,7 +18279,7 @@ a = Action("build < ${SOURCE\&.file} > $
The
\fBAction\fR() global function also takes an
\fBexitstatfunc\fR