summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-01-22 19:36:10 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-01-22 19:36:10 +0100
commite4e0c9e36afec29cf3f5e4f24c2b085a12c7837f (patch)
treef12cd2999f50a6e7f595fce1bd82bc313591546f
parent1dd5b8c88e6db11c731a92031a80beaacee47e46 (diff)
Add scripts to replace shotwell-video-thumbnailer
-rw-r--r--debian/changelog13
-rwxr-xr-xdebian/replace_thumbnailer.sh21
-rw-r--r--debian/shotwell.README.Debian27
-rw-r--r--debian/shotwell.examples1
-rw-r--r--debian/shotwell.postrm15
5 files changed, 77 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 08bbe5c..55b8d57 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+shotwell (0.20.2-2) UNRELEASED; urgency=medium
+
+ * Add user scripts to replace shotwell-video-thumbnailer
+ if the thumbnailer is broken (Closes: #768637):
+ - New files:
+ + debian/shotwell.README.Debian
+ + debian/replace_thumbnailer.sh
+ + debian/shotwell.postrm
+ + debian/shotwell.examples
+ - Thanks to Teo Romera <teoromera@gmail.com>.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Thu, 22 Jan 2015 18:03:59 +0100
+
shotwell (0.20.2-1) unstable; urgency=medium
* New upstream release (Closes: #769025).
diff --git a/debian/replace_thumbnailer.sh b/debian/replace_thumbnailer.sh
new file mode 100755
index 0000000..d70dec0
--- /dev/null
+++ b/debian/replace_thumbnailer.sh
@@ -0,0 +1,21 @@
+#! /bin/bash
+
+if [ -e /usr/lib/shotwell-video-thumbnailer.org ] ; then
+ echo ' /usr/lib/shotwell-video-thumbnailer.org exists!'
+ echo ' break'
+ exit 1
+fi
+
+echo '**** backup ****'
+mv /usr/lib/shotwell-video-thumbnailer /usr/lib/shotwell-video-thumbnailer.org
+
+echo '**** install ffmpegthumbnailer ****'
+apt-get install ffmpegthumbnailer -y
+
+echo '**** install new file ****'
+touch /usr/lib/shotwell-video-thumbnailer
+chmod --reference=/usr/lib/shotwell-video-thumbnailer.org /usr/lib/shotwell-video-thumbnailer
+
+echo '#! /bin/bash' >/usr/lib/shotwell-video-thumbnailer
+echo '' >>/usr/lib/shotwell-video-thumbnailer
+echo 'ffmpegthumbnailer -i "$1" -o - -c png' >>/usr/lib/shotwell-video-thumbnailer
diff --git a/debian/shotwell.README.Debian b/debian/shotwell.README.Debian
new file mode 100644
index 0000000..2d28b03
--- /dev/null
+++ b/debian/shotwell.README.Debian
@@ -0,0 +1,27 @@
+TROUBLESHOOTING
+---------------
+
+- video-thumbnailer
+
+ On problems with the shotwell-video-thumbnailer you can
+ switch to the ffmpegthumnailer. Please run as root:
+
+ 1. Backup /usr/lib/shotwell-video-thumbnailer:
+ * mv /usr/lib/shotwell-video-thumbnailer /usr/lib/shotwell-video-thumbnailer.org
+
+ 2. Install ffmpegthumbnailer:
+ * apt-get install ffmpegthumbnailer
+
+ 3. Create a new executable file:
+ * touch /usr/lib/shotwell-video-thumbnailer
+ * chmod --reference=/usr/lib/shotwell-video-thumbnailer.org /usr/lib/shotwell-video-thumbnailer
+
+ 4. Write into the new file:
+ * echo "#! /bin/bash" >/usr/lib/shotwell-video-thumbnailer
+ * echo "ffmpegthumnailer -i \"$1\" -o -b -c png >>/usr/lib/shotwell-video-thumbnailer
+
+ Or you can use the file replace_thumbnail.sh from the examples directory.
+
+ Thank to Teo Romera <teoromera@gmail.com>
+
+ \ No newline at end of file
diff --git a/debian/shotwell.examples b/debian/shotwell.examples
new file mode 100644
index 0000000..128a3c5
--- /dev/null
+++ b/debian/shotwell.examples
@@ -0,0 +1 @@
+debian/replace_thumbnailer.sh
diff --git a/debian/shotwell.postrm b/debian/shotwell.postrm
new file mode 100644
index 0000000..2dbce77
--- /dev/null
+++ b/debian/shotwell.postrm
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+set -e
+
+if [ "$1" = purge ]; then
+
+ #
+ # remove backup files
+ #
+ if [ -e /usr/lib/shotwell-video-thumbnailer.org ] ; then
+ rm -f /usr/lib/shotwell-video-thumbnailer.org
+ fi
+fi
+
+#DEBHELPER#