summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-04-05 08:49:36 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-04-05 08:49:36 +0200
commit163ce2a0caf0cef5352a6299c40239c57480740e (patch)
tree144c7eff41c6d77500c44203831b0024738924bd
parented257925f271e8e729d425f2246015cb1cd591a8 (diff)
Add better debuging
-rw-r--r--debian/changelog12
-rwxr-xr-xdebian/rules13
l---------debian/shotwell-common.README.Debian1
-rw-r--r--debian/shotwell-dbg.README.Debian8
-rw-r--r--debian/shotwell.docs (renamed from debian/docs)0
5 files changed, 33 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bb78e7e..acaa0b1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,18 @@ shotwell (0.22.0-1) UNRELEASED; urgency=medium
- debían/patches/500-buildflags.patch
* Remove upstream applied patch:
- debian/patches/505-fix-viewer-desktop-file.patch
+ * For better debuging:
+ - shotwell-dbg:
+ + Add the tempoary *.c files produced by valac
+ into temp-source.tar.xz placed at the doc directory.
+ - debian/rules:
+ + Add --debug as configure parameter.
+ + Add override_dh_compress to exclude the *.tar.xz from compress
+ - debian/docs:
+ + Move to shotwell.docs
+ - New debian/shotwell-dbg.README.Debian.
+ - New link from debian/shotwell.README.Debian to
+ debian/shotwell-common.README.Debian
-- Jörg Frings-Fürst <debian@jff-webhosting.net> Fri, 03 Apr 2015 13:16:32 +0200
diff --git a/debian/rules b/debian/rules
index 1d42699..460f96d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,10 +8,21 @@ export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
dh $@
override_dh_auto_configure:
- ./configure --prefix=/usr --libexec=/usr/lib --disable-schemas-compile
+ ./configure --prefix=/usr --libexec=/usr/lib --disable-schemas-compile --debug
+
+override_dh_install:
+ dh_install
+ mkdir -p debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
+ find -type f -name '*.c' -exec cp --parent '{}' debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source/ ';'
+ cd debian/shotwell-dbg/usr/share/doc/shotwell-dbg && \
+ tar cJf temp-source.tar.xz temp-source
+ rm -fr debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
override_dh_installchangelogs:
dh_installchangelogs NEWS
override_dh_strip:
dh_strip --dbg-package=shotwell-dbg
+
+override_dh_compress:
+ dh_compress -X.tar.xz
diff --git a/debian/shotwell-common.README.Debian b/debian/shotwell-common.README.Debian
new file mode 120000
index 0000000..e5d7439
--- /dev/null
+++ b/debian/shotwell-common.README.Debian
@@ -0,0 +1 @@
+shotwell.README.Debian \ No newline at end of file
diff --git a/debian/shotwell-dbg.README.Debian b/debian/shotwell-dbg.README.Debian
new file mode 100644
index 0000000..de005c1
--- /dev/null
+++ b/debian/shotwell-dbg.README.Debian
@@ -0,0 +1,8 @@
+
+For debuging you can copy the files from temp-source.tar.xz into
+your source directory (//usr/src/shotwell-VERSION) or you can
+set the dircetory for gdb with the commandline parameter --directory=DIR.
+
+For other debugger please read the docs.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Fri, 03 Apr 2015 13:16:32 +0200
diff --git a/debian/docs b/debian/shotwell.docs
index e4cf55f..e4cf55f 100644
--- a/debian/docs
+++ b/debian/shotwell.docs