summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-02-01 22:04:04 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-02-01 22:04:04 +0100
commit818b78e9ca20f25a63ab262b8d2852158df64aa5 (patch)
treed96e49473fed42e2872cecf8969ee2ca438ac9d6
parentd2fbbed6c9e7da895915ef57ae57be63a6bfe4a7 (diff)
FTBFS at i386 & powerpc
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/500-buildflags.patch13
-rwxr-xr-xdebian/rules4
3 files changed, 20 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 79afab5..68bb0a9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,9 +8,12 @@ shotwell (0.20.2-2) UNRELEASED; urgency=medium
+ debian/shotwell.postrm
+ debian/shotwell.examples
- Thanks to Teo Romera <teoromera@gmail.com>.
- * Add debian/505-fix-viewer-desktop-file.patch to correct build of
- shotwell-viewer.desktop (Closes: #776745).
- - thanks to Raphaël Halimi <raphael.halimi@gmail.com>.
+ * debian/patches:
+ - Add 505-fix-viewer-desktop-file.patch to correct build of
+ shotwell-viewer.desktop (Closes: #776745).
+ + thanks to Raphaël Halimi <raphael.halimi@gmail.com>.
+ - Rewrite 500-buildflags.patch to prevent FTBFS at
+ architectures i386 and powerpc.
* debian/control:
- Add Build-Depends libicu-dev for missing unicode/ucnv.h.
diff --git a/debian/patches/500-buildflags.patch b/debian/patches/500-buildflags.patch
index fa493ab..46cf411 100644
--- a/debian/patches/500-buildflags.patch
+++ b/debian/patches/500-buildflags.patch
@@ -16,7 +16,18 @@ Index: trunk/Makefile
# REQUIRED_CFLAGS absolutely get appended to CFLAGS, whatever the
# the value of CFLAGS in the environment
-REQUIRED_CFLAGS := -fPIC
-+REQUIRED_CFLAGS := -fPIC -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2
++REQUIRED_CFLAGS := -g -O2 -fPIE -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2
# setting CFLAGS in configure.mk overrides build type
ifndef CFLAGS
+@@ -410,8 +411,8 @@ PLUGIN_CFLAGS = -O2 -g -pipe
+ endif
+ endif
+
+-CFLAGS += $(PROFILE_FLAGS) $(REQUIRED_CFLAGS)
+-PLUGIN_CFLAGS += $(PROFILE_FLAGS) $(REQUIRED_CFLAGS)
++CFLAGS += $(PROFILE_FLAGS) $(REQUIRED_CFLAGS) -fstack-protector-strong
++PLUGIN_CFLAGS += $(PROFILE_FLAGS) $(REQUIRED_CFLAGS) -fPIC -fno-stack-protector
+
+ # Required for gudev-1.0
+ CFLAGS += -DG_UDEV_API_IS_SUBJECT_TO_CHANGE
diff --git a/debian/rules b/debian/rules
index 71e7242..1d42699 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,10 +5,10 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
%:
- dh $@
+ dh $@
override_dh_auto_configure:
- ./configure --debug --prefix=/usr --libexec=/usr/lib --disable-schemas-compile
+ ./configure --prefix=/usr --libexec=/usr/lib --disable-schemas-compile
override_dh_installchangelogs:
dh_installchangelogs NEWS