summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2023-06-14 20:36:17 +0200
committerJörg Frings-Fürst <debian@jff.email>2023-06-14 20:36:17 +0200
commit31804433d72460cbe0a39f9f8ea5e76058d84cda (patch)
tree2084a84c39f159c6aea254775dc0880d52579d45 /data/meson.build
parenta9898fb3f39c44a85876930ef6b2558052569ae6 (diff)
parentd443a3c2509889533ca812c163056bace396b586 (diff)
Update upstream source from tag 'upstream/0.32.1'
Update to upstream version '0.32.1' with Debian dir c460ad6e13d3c39eaa2d5399059385e64e6fba4c
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/data/meson.build b/data/meson.build
new file mode 100644
index 0000000..798ea38
--- /dev/null
+++ b/data/meson.build
@@ -0,0 +1,39 @@
+if get_option('install_apport_hook')
+ subdir('apport')
+endif
+
+subdir('gsettings')
+subdir('icons')
+
+podir = join_paths('..', 'po')
+
+i18n.merge_file(input : 'org.gnome.Shotwell.appdata.xml.in',
+ output : 'org.gnome.Shotwell.appdata.xml',
+ po_dir : join_paths('..', 'po'),
+ type : 'xml',
+ install: true,
+ install_dir : join_paths(get_option('datadir'), 'metainfo'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell.desktop.in',
+ output: 'org.gnome.Shotwell.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell-Viewer.desktop.in',
+ output: 'org.gnome.Shotwell-Viewer.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell-Profile-Browser.desktop.in',
+ output: 'org.gnome.Shotwell-Profile-Browser.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+shotwell_resources = gnome.compile_resources('shotwell-resources',
+ 'org.gnome.Shotwell.gresource.xml')