summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2023-06-14 20:36:37 +0200
committerJörg Frings-Fürst <debian@jff.email>2023-06-14 20:36:37 +0200
commitbb80d3feebdc9acc52e3f4ad24084d8425f043a2 (patch)
tree2084a84c39f159c6aea254775dc0880d52579d45 /data/meson.build
parentb26ff0798252a1a8072dd2c7a67f6205de9fde11 (diff)
parent31804433d72460cbe0a39f9f8ea5e76058d84cda (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/data/meson.build b/data/meson.build
new file mode 100644
index 0000000..798ea38
--- /dev/null
+++ b/data/meson.build
@@ -0,0 +1,39 @@
+if get_option('install_apport_hook')
+ subdir('apport')
+endif
+
+subdir('gsettings')
+subdir('icons')
+
+podir = join_paths('..', 'po')
+
+i18n.merge_file(input : 'org.gnome.Shotwell.appdata.xml.in',
+ output : 'org.gnome.Shotwell.appdata.xml',
+ po_dir : join_paths('..', 'po'),
+ type : 'xml',
+ install: true,
+ install_dir : join_paths(get_option('datadir'), 'metainfo'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell.desktop.in',
+ output: 'org.gnome.Shotwell.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell-Viewer.desktop.in',
+ output: 'org.gnome.Shotwell-Viewer.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell-Profile-Browser.desktop.in',
+ output: 'org.gnome.Shotwell-Profile-Browser.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+shotwell_resources = gnome.compile_resources('shotwell-resources',
+ 'org.gnome.Shotwell.gresource.xml')