summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2023-06-14 20:35:58 +0200
committerJörg Frings-Fürst <debian@jff.email>2023-06-14 20:35:58 +0200
commitd443a3c2509889533ca812c163056bace396b586 (patch)
treee94ffc0d9c054ca4efb8fb327e18dfac88e15dc7 /data/meson.build
parentbb9797c14470641b082ebf635e2ae3cfd5f27a3b (diff)
New upstream version 0.32.1upstream/0.32.1
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/data/meson.build b/data/meson.build
new file mode 100644
index 0000000..798ea38
--- /dev/null
+++ b/data/meson.build
@@ -0,0 +1,39 @@
+if get_option('install_apport_hook')
+ subdir('apport')
+endif
+
+subdir('gsettings')
+subdir('icons')
+
+podir = join_paths('..', 'po')
+
+i18n.merge_file(input : 'org.gnome.Shotwell.appdata.xml.in',
+ output : 'org.gnome.Shotwell.appdata.xml',
+ po_dir : join_paths('..', 'po'),
+ type : 'xml',
+ install: true,
+ install_dir : join_paths(get_option('datadir'), 'metainfo'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell.desktop.in',
+ output: 'org.gnome.Shotwell.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell-Viewer.desktop.in',
+ output: 'org.gnome.Shotwell-Viewer.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+i18n.merge_file(input : 'org.gnome.Shotwell-Profile-Browser.desktop.in',
+ output: 'org.gnome.Shotwell-Profile-Browser.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+shotwell_resources = gnome.compile_resources('shotwell-resources',
+ 'org.gnome.Shotwell.gresource.xml')