summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-08-13 16:32:28 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-08-13 16:32:28 +0200
commit0f67b3cc674377559e66c5a6729fd499049a992f (patch)
treedb385afa84c09891e9a83c18b6e5436cf6e983ed /debian/rules
parentf8ca421bdacee8851965a4b802ada1d2366bdbc1 (diff)
parent6cee6189adf46287667c35707325dd0820ea9f33 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules30
1 files changed, 6 insertions, 24 deletions
diff --git a/debian/rules b/debian/rules
index f8d940b..7b659ca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,31 +10,13 @@ B_DATE:=$(shell LC_ALL=C date --utc -d "$(CHDATE)")
dh $@
override_dh_auto_configure:
- ./configure --prefix=/usr --libexec=/usr/lib --disable-schemas-compile
+ dh_auto_configure -- --prefix=/usr \
+ --libexec=/usr/lib \
+ --disable-schemas-compile
override_dh_install:
dh_install
- # Touch the generated C files with mtime of debian/changelog,
- # find -type f -name '*.c' -exec touch -r $(CURDIR)/debian/changelog {} \;
- # then install these C files required for debugging into the shotwell-dbg package.
- mkdir -p debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
- find -type f -name '*.c' -exec cp --parent '{}' debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source/ ';'
- cd debian/shotwell-dbg/usr/share/doc/shotwell-dbg && \
- tar --mode=go=rX,u+rw,a-s --mtime="$(B_DATE)" -cJf temp-source.tar.xz temp-source
- rm -fr debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
# Remove unwanted la files
- rm -f debian/shotwell/usr/lib/shotwell/plugins/builtin/*.la
- rm -f debian/shotwell/usr/lib/*.la
-
-override_dh_installchangelogs:
- dh_installchangelogs NEWS
-
-override_dh_strip:
- dh_strip --dbg-package=shotwell-dbg
-
-override_dh_compress:
- dh_compress -X.tar.xz
-
-override_dh_installman:
- dh_installman
- rm -fr debian/shotwell-common/usr/share/man
+ rm -f debian/shotwell/usr/lib/*/shotwell/plugins/builtin/*.la
+ rm -f debian/shotwell/usr/lib/*/*shotwell*.a
+ rm -f debian/shotwell/usr/lib/*/*shotwell*.la