summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-06-05 10:20:24 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-06-05 10:20:24 +0200
commit6d0ad872b67aa8632f7bb41009ae76816a52421c (patch)
tree4fe935e2c65c34a9b9479c9bbf3990be2d594e53 /debian/rules
parentbec5f87053759705fb77bae1aa378f2666c7d153 (diff)
renew patches; make build reproducible
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 3bdd2ba..dede84d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
-CHDATE:=$(shell dpkg-parsechangelog --show-field=Date)
+B_DATE:=$(shell LC_ALL=C date --utc -d "$(CHDATE)")
%:
dh $@
@@ -20,7 +20,7 @@ override_dh_install:
mkdir -p debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
find -type f -name '*.c' -exec cp --parent '{}' debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source/ ';'
cd debian/shotwell-dbg/usr/share/doc/shotwell-dbg && \
- tar --mtime="$(CHDATE)" -cJf temp-source.tar.xz temp-source
+ tar --mode=go=rX,u+rw,a-s --mtime="$(B_DATE)" -cJf temp-source.tar.xz temp-source
rm -fr debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
override_dh_installchangelogs: