summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2021-11-27 11:42:07 +0100
committerJörg Frings-Fürst <debian@jff.email>2021-11-27 11:42:07 +0100
commite96790e6cdfed20e1fd3b77011c6e75e70cd4624 (patch)
treea230d949c2c2a2426ce8ce0211e0ced831315767 /debian/rules
parent13fc9b3d7074bcf4063065dcba4162a3a69b7343 (diff)
Enable the apport option on Ubuntu
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index acbfebd..a772218 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,13 +4,18 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
+#Enable the apport option when building of Ubuntu
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
+ APPORT = -Dinstall-apport-hook=true
+endif
+
%:
dh $@ --buildsystem=meson --with gnome
override_dh_auto_configure:
dh_auto_configure -- \
--libexec=/usr/libexec \
- -Dunity-support=true
+ -Dunity-support=true $(APPORT)
override_dh_gnome_clean:
dh_gnome_clean --no-control