summaryrefslogtreecommitdiff
path: root/plugins/authenticator/shotwell/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:43:08 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:43:08 +0200
commit2b3f22361da0c1d8e6ce70d71352821758186db7 (patch)
tree5d10633b47369b3aa52a05bf889ede0dbe5ee108 /plugins/authenticator/shotwell/meson.build
parent211da5fc3048ca2b6ccee2166b0aaaade55cb84f (diff)
parentdc6c76eb04dfe3d4262a1806808f0bc0bf523238 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'plugins/authenticator/shotwell/meson.build')
-rw-r--r--plugins/authenticator/shotwell/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/plugins/authenticator/shotwell/meson.build b/plugins/authenticator/shotwell/meson.build
new file mode 100644
index 0000000..4404242
--- /dev/null
+++ b/plugins/authenticator/shotwell/meson.build
@@ -0,0 +1,28 @@
+authenticator_shotwell_sources = [
+ 'ShotwellAuthenticatorFactory.vala',
+ 'FacebookPublishingAuthenticator.vala',
+ 'FlickrPublishingAuthenticator.vala',
+ 'GoogleAuthenticator.vala',
+ 'OAuth1Authenticator.vala',
+ 'TumblrAuthenticator.vala'
+ ]
+
+authenticator_shotwell_resources = gnome.compile_resources('authenticator-resource',
+ 'org.gnome.Shotwell.Authenticator.gresource.xml',
+ source_dir : meson.source_root())
+
+authenticator_shotwell_deps = [gee, gtk, gio, soup, json_glib, sw_plugin,
+ sw_plugin_common_dep, json_glib, xml, webkit]
+
+authenticator = library('shotwell-authenticator',
+ authenticator_shotwell_sources + authenticator_shotwell_resources,
+ dependencies : authenticator_shotwell_deps,
+ include_directories : config_incdir,
+ version: meson.project_version(),
+ vala_args : ['--gresources',
+ 'org.gnome.Shotwell.Authenticator.gresource.xml'],
+ c_args :
+ '-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Authenticator"',
+ install: true)
+authenticator_dep = declare_dependency(include_directories : include_directories('.'),
+ link_with : authenticator)